aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend')
-rw-r--r--meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend11
1 files changed, 7 insertions, 4 deletions
diff --git a/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
index 1fccf80..951a34f 100644
--- a/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
+++ b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
@@ -1,4 +1,7 @@
-#FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
+# It is believed the eMMC configuration below makes the result AGL
+# reference hardware specific, mark it as such to try to prevent
+# unintended usage on other boards.
+COMPATIBLE_MACHINE = "agl-refhw-h3"
# There are hardware issues in using hyperflash. arm-trusted-firmware, optee and
# u-boot have to be stored into eMMC by using serial donwload.
@@ -6,20 +9,20 @@ EMMC_BOOT_OPTION = "RCAR_SA6_TYPE=1"
DDR_8G_OPTION= "RCAR_DRAM_LPDDR4_MEMCONF=1"
-ATFW_OPT_append_refhw = " ${EMMC_BOOT_OPTION} "
+ATFW_OPT_append_agl-refhw-h3 = " ${EMMC_BOOT_OPTION}"
# In arm-trusted-firmware-control.inc, a "extra_ipl_opt" task is appended to
# create firmware for 4x2g or 2x2g variation. it is supposed to use
# EXTRA_ATFW_OPT to customize the compiler opton.
#
-#EXTRA_ATFW_OPT_append_refhw = " ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION} "
+#EXTRA_ATFW_OPT_append_agl-refhw-h3 = " ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION}"
#
# Unfortunately in do_extra_ipl_opt() it use d.setVar() instead of d.appendVar()
# to setup EXTRA_ATFW_OPT variable which makes it impossible to customize it properly
# by others... Override it.
#
#
-do_ipl_opt_compile_refhw () {
+do_ipl_opt_compile_agl-refhw-h3 () {
oe_runmake distclean
oe_runmake bl2 bl31 dummytool PLAT=${PLATFORM} ${EXTRA_ATFW_OPT} ${ATFW_OPT_LOSSY} ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION}
}