summaryrefslogtreecommitdiffstats
path: root/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware')
-rw-r--r--meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
new file mode 100644
index 0000000..1fccf80
--- /dev/null
+++ b/meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_%.bbappend
@@ -0,0 +1,26 @@
+#FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
+
+# There are hardware issues in using hyperflash. arm-trusted-firmware, optee and
+# u-boot have to be stored into eMMC by using serial donwload.
+EMMC_BOOT_OPTION = "RCAR_SA6_TYPE=1"
+
+DDR_8G_OPTION= "RCAR_DRAM_LPDDR4_MEMCONF=1"
+
+ATFW_OPT_append_refhw = " ${EMMC_BOOT_OPTION} "
+
+# In arm-trusted-firmware-control.inc, a "extra_ipl_opt" task is appended to
+# create firmware for 4x2g or 2x2g variation. it is supposed to use
+# EXTRA_ATFW_OPT to customize the compiler opton.
+#
+#EXTRA_ATFW_OPT_append_refhw = " ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION} "
+#
+# Unfortunately in do_extra_ipl_opt() it use d.setVar() instead of d.appendVar()
+# to setup EXTRA_ATFW_OPT variable which makes it impossible to customize it properly
+# by others... Override it.
+#
+#
+do_ipl_opt_compile_refhw () {
+ oe_runmake distclean
+ oe_runmake bl2 bl31 dummytool PLAT=${PLATFORM} ${EXTRA_ATFW_OPT} ${ATFW_OPT_LOSSY} ${EMMC_BOOT_OPTION} ${DDR_8G_OPTION}
+}
+
> 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211