aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xw@renesas.com>2018-10-14 21:59:56 -0400
committerKhang Nguyen <khang.nguyen.xv@renesas.com>2018-10-29 13:41:32 +0700
commitaaa3afa257ba66a177fffb2935f097e5362acacf (patch)
tree1f04a9a99eb68c5f53151e5c26f6a790a85bae73
parentcb22fb911c59a24b40fa309cd2e633a17be4fdab (diff)
rcar-gen3: u-boot: Update u-boot according to BSP v3.8.0
This commit updates u-boot according to BSP v3.8.0. Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-bsp/u-boot/u-boot-common_2018.09.inc6
-rw-r--r--meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2018.09.bb23
2 files changed, 23 insertions, 6 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-common_2018.09.inc b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-common_2018.09.inc
index 3a991ae..f66ac8f 100644
--- a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-common_2018.09.inc
+++ b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot-common_2018.09.inc
@@ -6,10 +6,4 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
PE = "1"
-# We use the revision in order to avoid having to fetch it from the
-# repo during parse
-SRCREV = "f88b6facb87dc4a52f1630eb9d858c0f54c6628e"
-
-SRC_URI = "git://git.denx.de/u-boot.git"
-
S = "${WORKDIR}/git"
diff --git a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2018.09.bb b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2018.09.bb
index 37c21dc..2810bc4 100644
--- a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2018.09.bb
+++ b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2018.09.bb
@@ -1,4 +1,27 @@
require u-boot-common_${PV}.inc
require u-boot.inc
+require include/uboot-control.inc
DEPENDS += "bc-native dtc-native"
+
+UBOOT_URL = "git://github.com/renesas-rcar/u-boot.git"
+BRANCH = "v2018.09/rcar-3.8.0"
+
+SRC_URI = "${UBOOT_URL};branch=${BRANCH}"
+SRCREV = "70206a1b84e6e35c33b3760fae6a2a6dbe6ce534"
+PV = "v2018.09+git${SRCPV}"
+
+# Add u-boot options for H3
+EXTRA_OEMAKE_append_r8a7795 = " ${@get_uboot_config_opt(d)}"
+
+UBOOT_SREC ?= "u-boot-elf.srec"
+UBOOT_SREC_IMAGE ?= "u-boot-elf-${MACHINE}-${PV}-${PR}.srec"
+UBOOT_SREC_SYMLINK ?= "u-boot-elf-${MACHINE}.srec"
+
+do_deploy_append() {
+ install -m 644 ${B}/${UBOOT_SREC} ${DEPLOYDIR}/${UBOOT_SREC_IMAGE}
+ cd ${DEPLOYDIR}
+ rm -f ${UBOOT_SREC} ${UBOOT_SREC_SYMLINK}
+ ln -sf ${UBOOT_SREC_IMAGE} ${UBOOT_SREC_SYMLINK}
+ ln -sf ${UBOOT_SREC_IMAGE} ${UBOOT_SREC}
+}