summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-11-01 13:50:54 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-11-24 20:15:57 +0700
commitd6eff077c4a3afbe39f8ee1b2ad1a19a716ce31c (patch)
treebe9712be8138d2cf2caefa24d3ab0c51136dfd70
parentbe931f019eacc2ae019622079092792ba008e1b5 (diff)
rcar-gen3: systemd: WORKAROUND to fix timeout dev-ttySN.device
This commit makes backporting changes from upstream systemd to fix timeout dev-ttySN.device by following: [systemd] - Set journal RuntimeMaxSize to 64M as default [1] [systemd-serialgetty] - Use the default RestartSec [2] [1] From Poky rev: d41968d8a8bd572b2892762f7092868950465014 [2] From Systemd rev: 4bf04322b8b7ecca4f3d65cfc642d0ac16356129 Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-core/systemd/systemd-serialgetty.bbappend6
-rw-r--r--meta-rcar-gen3/recipes-core/systemd/systemd_%.bbappend8
2 files changed, 14 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-core/systemd/systemd-serialgetty.bbappend b/meta-rcar-gen3/recipes-core/systemd/systemd-serialgetty.bbappend
new file mode 100644
index 0000000..f8d6e66
--- /dev/null
+++ b/meta-rcar-gen3/recipes-core/systemd/systemd-serialgetty.bbappend
@@ -0,0 +1,6 @@
+# W/A to fix serial-getty@.service timeout
+do_install_append () {
+ sed -e "/Before=getty.target/a Before=getty@tty1.service" \
+ -e "/.*RestartSec.*/d" \
+ -i ${D}${systemd_unitdir}/system/serial-getty@.service
+}
diff --git a/meta-rcar-gen3/recipes-core/systemd/systemd_%.bbappend b/meta-rcar-gen3/recipes-core/systemd/systemd_%.bbappend
index f414a2b..1fe259a 100644
--- a/meta-rcar-gen3/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-rcar-gen3/recipes-core/systemd/systemd_%.bbappend
@@ -1 +1,9 @@
PACKAGECONFIG_remove = "timesyncd"
+
+# Set journal RuntimeMaxSize to 64M as default to fix timeout
+# dev-ttySN.device's when enable debug and use journal
+# as systemd.log_target
+do_install_append () {
+ sed -e 's/.*RuntimeMaxUse.*/RuntimeMaxUse=64M/' \
+ -i ${D}${sysconfdir}/systemd/journald.conf
+}