aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2018-05-15 16:19:36 -0400
committerRonan Le Martret <ronan.lemartret@iot.bzh>2018-09-04 12:57:53 +0000
commit4e8493f1769316a2099b0863a362bc3daac61c6d (patch)
tree54d5aea23d64e80f092f86f468ef29b8f384015f
parent2281ecfcc65a69c3e1a24fd88230b9ec78865270 (diff)
[COMMUNITY] U-Boot: Backport increase to CBSIZE/etc
Starting with v2017.09 of upstream U-Boot the console buffer and maxargs have been greatly increased. This is important for passing in longer kernel command lines to the kernel as is done in CI. Change-Id: I996aa7cec7a92b7d6d329a55edd24e85dbd81203 Bug-AGL: SPEC-1434 Signed-off-by: Tom Rini <trini@konsulko.com>
-rw-r--r--meta-rcar-gen3/recipes-bsp/u-boot/u-boot/0001-ARM-rmobile-Increase-console-buffer-sizes.patch33
-rw-r--r--meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb4
2 files changed, 36 insertions, 1 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot/0001-ARM-rmobile-Increase-console-buffer-sizes.patch b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot/0001-ARM-rmobile-Increase-console-buffer-sizes.patch
new file mode 100644
index 0000000..9b20b93
--- /dev/null
+++ b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot/0001-ARM-rmobile-Increase-console-buffer-sizes.patch
@@ -0,0 +1,33 @@
+From 48aa8126768fa5ba2fc3eee18722b5a7f9e145ff Mon Sep 17 00:00:00 2001
+From: Marek Vasut <marek.vasut@gmail.com>
+Date: Fri, 21 Jul 2017 23:16:08 +0200
+Subject: [PATCH 1/1] ARM: rmobile: Increase console buffer sizes
+
+Allow pasting extra long lines into the U-Boot console on RCar Gen3.
+This is OK since we have plenty of resources and it's convenient.
+
+Signed-off-by: Marek Vasut <marek.vasut+renesas@gmail.com>
+Cc: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
+Signed-off-by: Nobuhiro Iwamatsu <iwamatsu@nigauri.org>
+---
+diff --git a/include/configs/rcar-gen3-common.h b/include/configs/rcar-gen3-common.h
+index 6b58d208723e..1ba16a30fba8 100644
+--- a/include/configs/rcar-gen3-common.h
++++ b/include/configs/rcar-gen3-common.h
+@@ -87,11 +87,12 @@
+ #undef CONFIG_SYS_CONSOLE_OVERWRITE_ROUTINE
+ #undef CONFIG_SYS_CONSOLE_ENV_OVERWRITE
+
++#define CONFIG_SYS_CBSIZE 2048
++#define CONFIG_SYS_PBSIZE \
++ (CONFIG_SYS_CBSIZE + sizeof(CONFIG_SYS_PROMPT) + 16)
++#define CONFIG_SYS_BARGSIZE CONFIG_SYS_CBSIZE
+ #define CONFIG_SYS_LONGHELP
+-#define CONFIG_SYS_CBSIZE 256
+-#define CONFIG_SYS_PBSIZE 256
+-#define CONFIG_SYS_MAXARGS 16
+-#define CONFIG_SYS_BARGSIZE 512
++#define CONFIG_SYS_MAXARGS 64
+ #define CONFIG_SYS_BAUDRATE_TABLE { 115200, 38400 }
+
+ /* MEMORY */
diff --git a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb
index 6ca5ca5..23c3dd5 100644
--- a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb
+++ b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb
@@ -7,7 +7,9 @@ DEPENDS += "dtc-native"
UBOOT_URL = "git://github.com/renesas-rcar/u-boot.git"
BRANCH = "v2015.04/rcar-3.7.0"
-SRC_URI = "${UBOOT_URL};branch=${BRANCH}"
+
+SRC_URI = "${UBOOT_URL};branch=${BRANCH} \
+ file://0001-ARM-rmobile-Increase-console-buffer-sizes.patch"
SRCREV = "6a82c94590cda5d61720798979bdf0144b9569b9"
PV = "v2015.04+git${SRCPV}"