aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-03-29 15:12:49 +0200
committerRonan Le Martret <ronan.lemartret@iot.bzh>2018-09-06 15:39:18 +0000
commit52f59ee1837256c2c0d0b10be91921e972db5898 (patch)
tree8b31d71a83559dded2ac0172891dbc96a628e974
parentc8cf57c626c5d68ee4d00d689315b0754334b7c7 (diff)
[COMMUNITY] add depends on mesa to gles-user-module
the populate_sysroot of gles-user-module must depends on the populate_sysroot of the virtual/mesa, because header from gles-user-module depends on the header from virtual/mesa. Change-Id: I8368bba6a19ca628a3496a3eebbc18a3c41c322d Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
index a60a0a5..105ec6a 100644
--- a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
@@ -32,6 +32,9 @@ SYSTEMD_SERVICE_${PN} = "rc.pvr.service"
do_populate_lic[noexec] = "1"
do_compile[noexec] = "1"
+#The headers of gles-user-module need headers from virtual/mesa.
+do_populate_sysroot[depends] += "virtual/mesa:do_populate_sysroot"
+
do_install() {
# Install configuration files
install -d ${D}/${sysconfdir}/init.d