aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-05-22 16:19:05 +0700
committerKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-06-18 17:55:58 +0700
commite23d0a9f7c3943d57ffd3c243314e6a38d2de228 (patch)
treec0b61ff0ebb8edf15c744f9c19297ba3266c3982
parent99bc1ac77c83f53ea321b20ee4ccb5d4cc8daee5 (diff)
rcar-gen3: weston: Set XDG_RUNTIME_DIR for SSH login
This commit adds weston.sh script into /etc/profile.d to set XDG_RUNTIME_DIR automatically when using SSH login. Signed-off-by: Khang Nguyen <khang.nguyen.xv@rvc.renesas.com> Signed-off-by: Thuy Tran <thuy.tran.xh@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rwxr-xr-xmeta-rcar-gen3/recipes-graphics/wayland/weston/weston.sh5
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston_2.0.0.bbappend6
2 files changed, 11 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston/weston.sh b/meta-rcar-gen3/recipes-graphics/wayland/weston/weston.sh
new file mode 100755
index 0000000..33ed8a4
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston/weston.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+if test -z "$XDG_RUNTIME_DIR"; then
+ export XDG_RUNTIME_DIR=/run/user/$UID
+fi
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston_2.0.0.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston_2.0.0.bbappend
index 86518df..bdc768a 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston_2.0.0.bbappend
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston_2.0.0.bbappend
@@ -15,6 +15,7 @@ SRC_URI_append = " \
file://xwayland.weston-start \
file://weston.ini \
file://weston_v4l2.ini \
+ file://weston.sh \
"
S = "${WORKDIR}/git"
@@ -50,8 +51,13 @@ do_install_append() {
-e '$a\cursor-theme=default' \
-i ${D}/${sysconfdir}/xdg/weston/weston.ini
fi
+
+ # Set XDG_RUNTIME_DIR to /run/user/$UID (e.g. run/user/0)
+ install -d ${D}/${sysconfdir}/profile.d
+ install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
}
FILES_${PN}_append = " \
${sysconfdir}/xdg/weston/weston.ini \
+ ${sysconfdir}/profile.d/weston.sh \
"