aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-05-28 14:47:58 +0700
committerKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-06-18 17:55:58 +0700
commitf5258275efbe31cac6cd121e3f31369eb09e7929 (patch)
treeff6849c10c6e9b7f769f08527a3568bc505119d5
parent917ffec2abdeb8c5c2eda7693ec8541433aa57bf (diff)
rcar-gen3: gles-user-module: Remove hard path
This replaces "/usr/local" with path "${RENESAS_DATADIR}" using RENESAS_DATADIR = "/usr/local" from meta-rcar-gen3/include/rcar-gen3-path-common.inc. Signed-off-by: Khang Nguyen <khang.nguyen.xv@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
index 59a188e..a60a0a5 100644
--- a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
@@ -1,4 +1,5 @@
require include/gles-control.inc
+require include/rcar-gen3-path-common.inc
DESCRIPTION = "PowerVR GPU user module"
LICENSE = "CLOSED"
@@ -52,8 +53,8 @@ do_install() {
# Install pre-builded binaries
install -d ${D}/${libdir}
install -m 755 ${S}/${libdir}/*.so ${D}/${libdir}/
- install -d ${D}/${exec_prefix}/local/bin
- install -m 755 ${S}/${exec_prefix}/local/bin/dlcsrv_REL ${D}/${exec_prefix}/local/bin/dlcsrv_REL
+ install -d ${D}${RENESAS_DATADIR}/bin
+ install -m 755 ${S}/usr/local/bin/dlcsrv_REL ${D}${RENESAS_DATADIR}/bin/dlcsrv_REL
install -d ${D}/lib/firmware
install -m 644 ${S}/lib/firmware/* ${D}/lib/firmware/
@@ -92,7 +93,7 @@ FILES_${PN} = " \
${sysconfdir}/* \
${libdir}/* \
/lib/firmware/rgx.fw* \
- /usr/local/bin/* \
+ ${RENESAS_DATADIR}/bin/* \
${exec_prefix}/bin/* \
"