aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-05-28 14:24:15 +0700
committerKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-06-18 17:55:58 +0700
commitfd078b6ece537d986852cb827bd21e022a797b2f (patch)
treeb48daefdfbc4eb5d2469185b4c0920352fcd7040
parentaec5ee3128465742b200a1765d825ca5734a1efb (diff)
rcar-gen3: glmark2: Remove no longer used patch
The source code has been updated, hence the WORKAROUND patch was not used anymore. Signed-off-by: Khang Nguyen <khang.nguyen.xv@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-benchmark/glmark2/glmark2/0001-gl-state-egl-Avoid-build-failure-due-to-miss-macro-d.patch44
-rw-r--r--meta-rcar-gen3/recipes-benchmark/glmark2/glmark2_git.bbappend5
2 files changed, 0 insertions, 49 deletions
diff --git a/meta-rcar-gen3/recipes-benchmark/glmark2/glmark2/0001-gl-state-egl-Avoid-build-failure-due-to-miss-macro-d.patch b/meta-rcar-gen3/recipes-benchmark/glmark2/glmark2/0001-gl-state-egl-Avoid-build-failure-due-to-miss-macro-d.patch
deleted file mode 100644
index db61eb2..0000000
--- a/meta-rcar-gen3/recipes-benchmark/glmark2/glmark2/0001-gl-state-egl-Avoid-build-failure-due-to-miss-macro-d.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From b2c3e7f58710bb5cc119845d72bc7c4ba5b4cb16 Mon Sep 17 00:00:00 2001
-From: Khang Nguyen <khang.nguyen.xv@rvc.renesas.com>
-Date: Tue, 13 Mar 2018 13:28:52 +0700
-Subject: [PATCH] gl-state-egl: Avoid build failure due to miss macro
- declaration
-
-This commit avoids the following error:
-
-| ../src/gl-state-egl.cpp: In member function 'bool GLStateEGL::gotValidDisplay()':
-| ../src/gl-state-egl.cpp:420:41: error: 'EGL_PLATFORM_GBM_KHR' was not declared in this scope
-| #define GLMARK2_NATIVE_EGL_DISPLAY_ENUM EGL_PLATFORM_GBM_KHR
-| ^
-| ../src/gl-state-egl.cpp:444:17: note: in expansion of macro 'GLMARK2_NATIVE_EGL_DISPLAY_ENUM'
-| GLMARK2_NATIVE_EGL_DISPLAY_ENUM, native_display_, NULL);
-| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-| ../src/gl-state-egl.cpp:420:41: note: suggested alternative: 'EGL_PLATFORM_GBM_MESA'
-| #define GLMARK2_NATIVE_EGL_DISPLAY_ENUM EGL_PLATFORM_GBM_KHR
-| ^
-| ../src/gl-state-egl.cpp:444:17: note: in expansion of macro 'GLMARK2_NATIVE_EGL_DISPLAY_ENUM'
-| GLMARK2_NATIVE_EGL_DISPLAY_ENUM, native_display_, NULL);
-| ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-Signed-off-by: Khang Nguyen <khang.nguyen.xv@rvc.renesas.com>
----
- src/gl-state-egl.cpp | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/src/gl-state-egl.cpp b/src/gl-state-egl.cpp
-index 6f4f420..0edcdc1 100644
---- a/src/gl-state-egl.cpp
-+++ b/src/gl-state-egl.cpp
-@@ -440,8 +440,7 @@ GLStateEGL::gotValidDisplay()
- eglGetProcAddress("eglGetPlatformDisplayEXT"));
-
- if (get_platform_display != nullptr) {
-- egl_display_ = get_platform_display(
-- GLMARK2_NATIVE_EGL_DISPLAY_ENUM, native_display_, NULL);
-+ eglGetDisplay(native_display_);
- }
-
- if (!egl_display_) {
---
-2.7.4
-
diff --git a/meta-rcar-gen3/recipes-benchmark/glmark2/glmark2_git.bbappend b/meta-rcar-gen3/recipes-benchmark/glmark2/glmark2_git.bbappend
index 4cfc8d8..460c4b0 100644
--- a/meta-rcar-gen3/recipes-benchmark/glmark2/glmark2_git.bbappend
+++ b/meta-rcar-gen3/recipes-benchmark/glmark2/glmark2_git.bbappend
@@ -1,7 +1,2 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI_append = " \
- file://0001-gl-state-egl-Avoid-build-failure-due-to-miss-macro-d.patch \
-"
-
PACKAGECONFIG[drm-gl] = ",,virtual/libgl libdrm libgbm"
PACKAGECONFIG[drm-gles2] = ",,virtual/libgles2 libdrm libgbm"