aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuy Dang <duy.dang.yw@rvc.renesas.com>2018-11-12 11:01:11 +0700
committerDuy Dang <duy.dang.yw@rvc.renesas.com>2018-12-20 13:09:08 +0700
commit0da1335346af6d7a6956f2f9a6e9fe801c382075 (patch)
tree0190f1c0ed8f1d9bfef8ac430f7ca58f58a347d6
parent98d9fe94d9ba7370bd1d2e5f21d5856b3c0619d8 (diff)
rcar-gen3: openavnu: Fix do_configure error
This commit fixes the error when re-build openavnu: | aarch64-poky-linux-gcc: error: unrecognized argument in option '-mcmodel=kernel' | aarch64-poky-linux-gcc: note: valid arguments to '-mcmodel=' are: large small tiny | aarch64-poky-linux-gcc: error: unrecognized command line option '-mno-red-zone'; did you mean '-fno-regmove'? The error comes from cleaning other unnecessary modules which have some make flags for x86_64 architecture. In AVB software, Renesas BSP uses some daemons (mrpd maap gptp shaper) only. Hence, this fix makes do_configure not to clean all AVB modules to avoid the above error. Signed-off-by: Duy Dang <duy.dang.yw@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-multimedia/openavnu/openavnu_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-multimedia/openavnu/openavnu_git.bb b/meta-rcar-gen3/recipes-multimedia/openavnu/openavnu_git.bb
index c4f71b4..486a5b6 100644
--- a/meta-rcar-gen3/recipes-multimedia/openavnu/openavnu_git.bb
+++ b/meta-rcar-gen3/recipes-multimedia/openavnu/openavnu_git.bb
@@ -27,6 +27,10 @@ S = "${WORKDIR}/git"
EXTRA_OEMAKE = "'CC=${CC}' 'CXX=${CXX}'"
+do_configure() {
+ oe_runmake daemons_all_clean
+}
+
do_compile() {
oe_runmake daemons_all
}