aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xw@renesas.com>2018-12-03 20:10:17 +0700
committerDuy Dang <duy.dang.yw@rvc.renesas.com>2018-12-20 09:47:58 +0700
commit81198ba799c0232b737e2d521cbb3d1f6ebcd325 (patch)
treeeab6a4bcbf4bb957dcc10558ce8cfe803fc8b86d
parent1a2393c84e33afdecb09f7988e346a036f62ea44 (diff)
rcar-gen3: u-boot: Drop SoC name in srec files
This commit updates do_deploy function to drop the SoC name when deploying srec files, the purpose is to keep the legacy name of U-Boot build results. Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2018.09.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2018.09.bb b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2018.09.bb
index 50ba275..654b5ef 100644
--- a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2018.09.bb
+++ b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2018.09.bb
@@ -24,6 +24,7 @@ do_deploy_append() {
j=$(expr $j + 1);
if [ $j -eq $i ]
then
+ type=${type#*_}
install -m 644 ${B}/${config}/${UBOOT_SREC} ${DEPLOYDIR}/u-boot-elf-${type}-${PV}-${PR}.${UBOOT_SREC_SUFFIX}
cd ${DEPLOYDIR}
ln -sf u-boot-elf-${type}-${PV}-${PR}.${UBOOT_SREC_SUFFIX} u-boot-elf-${type}.${UBOOT_SREC_SUFFIX}