aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuy Dang <duy.dang.yw@rvc.renesas.com>2019-01-21 10:16:30 +0700
committerThuy Tran <thuy.tran.xh@renesas.com>2019-05-23 16:16:13 +0700
commit464b9c3266ab23de27f740b9b30a75fd57bb3243 (patch)
tree13ae865cc75266cbc217a233eea7aee39a4f89ec
parent3ae3d87b5c06367892129dab2a4042dd608702e8 (diff)
rcar-gen3: gles-user-module: Fix wrong condition
The condition "if [ <true/false> ]" always returns true, because it checks for non-empty string. Fix it by removing the brackets. Change-Id: Ib9fe24e6a8ef3f93e9ed17d118775b54765ae5bb Signed-off-by: Duy Dang <duy.dang.yw@renesas.com> Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com> (cherry picked from commit 5df4c994040171bd7bf13c625b1fef295d1e9c9c)
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
index ba425b9..29f25c9 100644
--- a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
@@ -80,7 +80,7 @@ do_install() {
fi
# Install systemd service
- if [ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} ]; then
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} ; then
install -d ${D}${systemd_system_unitdir}/
install -m 644 ${WORKDIR}/rc.pvr.service ${D}${systemd_system_unitdir}/
install -d ${D}${exec_prefix}/bin