aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@renesas.com>2018-07-17 16:08:23 +0700
committerThuy Tran <thuy.tran.xh@renesas.com>2019-02-28 09:43:53 +0700
commit8c65ee48730882afd0f99ac10acbbe46ecc5c48d (patch)
tree03b1f477b526cbf357faeda00b93c5f82ad010b5
parent73716ce27ed60f5b470fca2e502ba4770b9d0ef4 (diff)
rcar-gen3: adsp-if-module: WORKAROUND to fix compile error with GCC 8.1
Current ADSP source code will get compilation error with GCC 8.1 due to new command-line option -Wpacked-not-aligned have been added for the C and C++ compilers. | In file included from ./include/xf-ap.h:46, from proxy/xf-proxy.c:26: | ./include/xf-ap-msg.h:128:1: error: alignment 1 of 'struct xf_ext_param_msg' is less than 4 [-Werror=packed-not-ali| gned] | } __attribute__ ((__packed__)) xf_ext_param_msg_t; | ^ | In file included from ./include/xf-ap.h:46, from proxy/xf-trace.c:20: | ./include/xf-ap-msg.h:128:1: error: alignment 1 of 'struct xf_ext_param_msg' is less than 4 [-Werror=packed-not-ali| gned] | } __attribute__ ((__packed__)) xf_ext_param_msg_t; | ^ This commit silenced -Wpacked-not-aligned errors when compiling this ADSP module. Signed-off-by: Thuy Tran <thuy.tran.xh@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-multimedia/adsp-module/adsp-if-module.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-multimedia/adsp-module/adsp-if-module.bb b/meta-rcar-gen3/recipes-multimedia/adsp-module/adsp-if-module.bb
index 1689746..52b2627 100644
--- a/meta-rcar-gen3/recipes-multimedia/adsp-module/adsp-if-module.bb
+++ b/meta-rcar-gen3/recipes-multimedia/adsp-module/adsp-if-module.bb
@@ -19,6 +19,7 @@ do_configure[noexec] = "1"
# Don't use EXTRA_OEMAKE default value to avoid default CFLAGS, LDFLAGS
# of poky override the CFLAGS, LDFLAGS inside RCG3AHIFL4101ZDP/Makefile
EXTRA_OEMAKE = "INCSHARED=${STAGING_INCDIR}"
+CFLAGS += "-Wno-packed-not-aligned"
do_compile() {
cd ${S}