aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Lawrence <stephen.lawrence@renesas.com>2016-10-05 19:23:25 +0100
committerKhiem Nguyen <khiem.nguyen.xt@renesas.com>2017-03-27 03:32:57 +0000
commitbad228d40fbec195d2ec0240e34606bcd08126cb (patch)
treec07975d2261f6bfdddeee16259afc2b556b56ba6
parentee4b23c1e6b9249c0d9c02a6e4826605cd16832a (diff)
rcar-gen3: gles-user-module: Fix issue that results in rc.pvr not being installed
The poky systemd class has a do_install() postfunc rm_sysvinit_initddir() that deletes the /etc/init.d directory of a package if the systemd system unit directory contains some files. gles-user-module supports both systemd and sysV but uses /etc/init.d in both cases as the location of the required script rc.pvr. In the case when systemd only is enabled, the class deletes the init.d directory and the file. Until the script is converted to a service file workaround the issue by moving the install location of rc.pvr when systemd alone is used. (cherry picked with edits from commit 50b03a9d6cc674144f42a656b43d3e3f2805661c) Change-Id: I8b29d610d6465bc8a786ff330f896832824f0932 Signed-off-by: Stephen Lawrence <stephen.lawrence@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb3
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module/rc.pvr.service4
2 files changed, 5 insertions, 2 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
index 16ed079..549da65 100644
--- a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
@@ -76,6 +76,8 @@ do_install() {
if [ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} ]; then
install -d ${D}/${systemd_system_unitdir}/
install -m 644 ${WORKDIR}/rc.pvr.service ${D}/${systemd_system_unitdir}/
+ install -d ${D}/${exec_prefix}/bin
+ install -m 755 ${S}/${sysconfdir}/init.d/rc.pvr ${D}/${exec_prefix}/bin/
fi
}
@@ -89,6 +91,7 @@ FILES_${PN} = " \
${libdir}/* \
/lib/firmware/rgx.fw* \
/usr/local/bin/* \
+ ${exec_prefix}/bin/* \
"
FILES_${PN}-dev = " \
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module/rc.pvr.service b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module/rc.pvr.service
index fa7ad7b..73e5df8 100644
--- a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module/rc.pvr.service
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module/rc.pvr.service
@@ -2,8 +2,8 @@
Description=PowerVR consumer services
[Service]
-ExecStart=/etc/init.d/rc.pvr start
-ExecStop=/etc/init.d/rc.pvr stop
+ExecStart=/usr/bin/rc.pvr start
+ExecStop=/usr/bin/rc.pvr stop
Type=oneshot
RemainAfterExit=yes