aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThao Nguyen <thao.nguyen.yb@rvc.renesas.com>2017-02-16 19:13:08 +0700
committerKhiem Nguyen <khiem.nguyen.xt@renesas.com>2017-03-27 03:31:05 +0000
commitdcbb211458beab5cc225e0c8fc0c9df28d20c946 (patch)
treed352c80ac728657b40fee2538faa602db37d2593
parentc1bb03e4da7362274ee68a1191014eeeb6fcff2f (diff)
rcar-gen3: weston: Fix issue of v4l2-renderer for ULCB
Because ULCB is not mounted VIN, they will use /dev/media0 for v4l2-renderer. Change-Id: Idbd40a5745c8f109455c57f77bb605c9f2964d78 Signed-off-by: Thao Nguyen <thao.nguyen.yb@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
index 13f77b4..66dedfe 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
@@ -31,6 +31,9 @@ do_install_append() {
if [ "X${USE_MULTIMEDIA}" = "X1" ]; then
# install weston.ini as sample settings of v4l2-renderer
install -d ${D}/${sysconfdir}/xdg/weston
+ if [ "${MACHINE}" = "m3ulcb" -o "${MACHINE}" = "h3ulcb" ] ; then
+ sed -i 's|media1|media0|g' ${WORKDIR}/weston_v4l2.ini
+ fi
install -m 644 ${WORKDIR}/weston_v4l2.ini ${D}/${sysconfdir}/xdg/weston/weston.ini
else
# install weston.ini as sample settings of gl-renderer