aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-03-29 15:12:49 +0200
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-04-11 10:44:42 +0200
commite62952c3bee4173f4a0e5ed115056554fe6411be (patch)
treef9e16c6f062be40cf209a4f14939d8c58aeeea7d
parent4452094f996c54d33a5a5f5a4564b083369d0e4c (diff)
[COMMUNITY] add depends on mesa to gles-user-module
the populate_sysroot of gles-user-module must depends on the populate_sysroot of the virtual/mesa, because header from gles-user-module depends on the header from virtual/mesa. Change-Id: I8368bba6a19ca628a3496a3eebbc18a3c41c322d Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
index 549da65..ab21a76 100644
--- a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
@@ -29,6 +29,9 @@ SYSTEMD_SERVICE_${PN} = "rc.pvr.service"
do_populate_lic[noexec] = "1"
do_compile[noexec] = "1"
+#The headers of gles-user-module need headers from virtual/mesa.
+do_populate_sysroot[depends] += "virtual/mesa:do_populate_sysroot"
+
do_install() {
# Install configuration files
install -d ${D}/${sysconfdir}/init.d