aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-03-27 10:46:56 +0200
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-03-27 11:09:50 +0200
commitfaf3c2a2a2d4333c4d90f8a72da9a952a0f2d5ea (patch)
treec4a6b8cd57dccb3798acb071f3d8bee8892d1311
parent57a2b531391067a133228febcf1a89a304b84638 (diff)
[COMMUNITY] remove weston.ini from weston recipes
* Create a new recipes weston-ini-conf. * Benefit: If you change weston.ini, you don't have to rebuild weston. Bug-AGL: SPEC-477 Change-Id: I7a7ab91953b000bbef5d66e1dca840cdaec47f2d Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
-rw-r--r--meta-rcar-gen3/recipes-graphics/images/core-image-weston.bbappend2
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bb25
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/weston.ini (renamed from meta-rcar-gen3/recipes-graphics/wayland/weston/weston.ini)0
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/weston_v4l2.ini (renamed from meta-rcar-gen3/recipes-graphics/wayland/weston/weston_v4l2.ini)0
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend18
5 files changed, 27 insertions, 18 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/images/core-image-weston.bbappend b/meta-rcar-gen3/recipes-graphics/images/core-image-weston.bbappend
index e30bc2e..9bca7ad 100644
--- a/meta-rcar-gen3/recipes-graphics/images/core-image-weston.bbappend
+++ b/meta-rcar-gen3/recipes-graphics/images/core-image-weston.bbappend
@@ -1,2 +1,4 @@
require core-image-renesas-base.inc
require core-image-weston.inc
+
+CORE_IMAGE_BASE_INSTALL += "weston-ini-conf"
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bb b/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bb
new file mode 100644
index 0000000..6867e73
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf.bb
@@ -0,0 +1,25 @@
+LICENSE = "MIT"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI = " \
+ file://weston.ini \
+ file://weston_v4l2.ini \
+"
+
+do_install_append() {
+ if [ "X${USE_MULTIMEDIA}" = "X1" ]; then
+ # install weston.ini as sample settings of v4l2-renderer
+ install -d ${D}/${sysconfdir}/xdg/weston
+ install -m 644 ${WORKDIR}/weston_v4l2.ini ${D}/${sysconfdir}/xdg/weston/weston.ini
+ else
+ # install weston.ini as sample settings of gl-renderer
+ install -d ${D}/${sysconfdir}/xdg/weston
+ install -m 644 ${WORKDIR}/weston.ini ${D}/${sysconfdir}/xdg/weston/
+ fi
+}
+
+FILES_${PN}_append = " \
+ ${sysconfdir}/xdg/weston/weston.ini \
+"
+
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston/weston.ini b/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/weston.ini
index f31c290..f31c290 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston/weston.ini
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/weston.ini
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston/weston_v4l2.ini b/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/weston_v4l2.ini
index 8e2e70f..8e2e70f 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston/weston_v4l2.ini
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston-ini-conf/weston_v4l2.ini
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
index 3400c1f..cb56893 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston_1.11.0.bbappend
@@ -10,8 +10,6 @@ SRC_URI_remove = "https://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
SRC_URI_append = " \
git://github.com/renesas-rcar/weston.git;branch=${BRANCH} \
- file://weston.ini \
- file://weston_v4l2.ini \
"
S = "${WORKDIR}/git"
@@ -20,19 +18,3 @@ PACKAGECONFIG_append = " \
${@base_conditional('USE_MULTIMEDIA', '1', ' v4l2', '', d)} \
"
PACKAGECONFIG[v4l2] = " --enable-v4l2, --disable-v4l2,,kernel-module-vsp2driver"
-
-do_install_append() {
- if [ "X${USE_MULTIMEDIA}" = "X1" ]; then
- # install weston.ini as sample settings of v4l2-renderer
- install -d ${D}/${sysconfdir}/xdg/weston
- install -m 644 ${WORKDIR}/weston_v4l2.ini ${D}/${sysconfdir}/xdg/weston/weston.ini
- else
- # install weston.ini as sample settings of gl-renderer
- install -d ${D}/${sysconfdir}/xdg/weston
- install -m 644 ${WORKDIR}/weston.ini ${D}/${sysconfdir}/xdg/weston/
- fi
-}
-
-FILES_${PN}_append = " \
- ${sysconfdir}/xdg/weston/weston.ini \
-"