aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThao Nguyen <thao.nguyen.yb@rvc.renesas.com>2017-03-30 15:38:11 +0700
committerKhiem Nguyen <khiem.nguyen.xt@renesas.com>2017-04-19 09:58:06 +0700
commit2e9335eef068795ddc426f125c0e37c3e85dd054 (patch)
tree6378959f110266673877485f0f67009c9587eba7
parentc00adcbc48a06280562c4bf227087dde63b36394 (diff)
rcar-gen3: gles-user-module: Change name of graphics initscript
This patch changes the GFX initscript from rc.pvr to prvinit. Due to Linux culture, filename on /usr/bin should not have rc.* format. Change-Id: I0fd9c1862b5f58219190e7f14ee3baf0ea465f9f Signed-off-by: Thao Nguyen <thao.nguyen.yb@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb4
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module/rc.pvr.service4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
index 549da65..a59aa88 100644
--- a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
@@ -22,7 +22,7 @@ SRC_URI_append = " \
inherit update-rc.d systemd
-INITSCRIPT_NAME = "rc.pvr"
+INITSCRIPT_NAME = "pvrinit"
INITSCRIPT_PARAMS = "start 7 5 2 . stop 62 0 1 6 ."
SYSTEMD_SERVICE_${PN} = "rc.pvr.service"
@@ -77,7 +77,7 @@ do_install() {
install -d ${D}/${systemd_system_unitdir}/
install -m 644 ${WORKDIR}/rc.pvr.service ${D}/${systemd_system_unitdir}/
install -d ${D}/${exec_prefix}/bin
- install -m 755 ${S}/${sysconfdir}/init.d/rc.pvr ${D}/${exec_prefix}/bin/
+ install -m 755 ${S}/${sysconfdir}/init.d/rc.pvr ${D}/${exec_prefix}/bin/pvrinit
fi
}
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module/rc.pvr.service b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module/rc.pvr.service
index 73e5df8..f940776 100644
--- a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module/rc.pvr.service
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module/rc.pvr.service
@@ -2,8 +2,8 @@
Description=PowerVR consumer services
[Service]
-ExecStart=/usr/bin/rc.pvr start
-ExecStop=/usr/bin/rc.pvr stop
+ExecStart=/usr/bin/pvrinit start
+ExecStop=/usr/bin/pvrinit stop
Type=oneshot
RemainAfterExit=yes