aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYusuke Goda <yusuke.goda.sx@renesas.com>2017-03-28 16:38:56 +0900
committerKhiem Nguyen <khiem.nguyen.xt@renesas.com>2017-04-19 09:59:28 +0700
commit39c23f7fecc60a03a2a3f558099e9f7e7fcbb7d0 (patch)
tree04db650ce7f80511cadfd1ed7a39070d554ce101
parent9f83adbe44de5313e1a22d69c2de5264dfa7b5e9 (diff)
rcar-gen3: arm-trusted-firmware: Set PMIC_LEVEL_MODE to 0 for ULCB
The operation mode of the PMIC for Salvator-X and ULCB are different: - ULCB : PULSE MODE (PMIC_LEVEL_MODE=0) - Salvator-X : LEVEL MODE (PMIC_LEVEL_MODE=1(default)) This commit updates arm-trusted-firmware recipe to check PMIC_LEVEL_MODE option and to control the corresponding PMIC. Change-Id: I152c1286d525000f58c678ec37eb6aac9502ac45 Signed-off-by: Yusuke Goda <yusuke.goda.sx@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb b/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
index 3f23688..bef24a4 100644
--- a/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
@@ -21,7 +21,7 @@ PLATFORM = "rcar"
ATFW_OPT_LOSSY = "${@base_conditional("USE_MULTIMEDIA", "1", "RCAR_LOSSY_ENABLE=1", "", d)}"
ATFW_OPT_r8a7795 = "LSI=H3 RCAR_DRAM_SPLIT=1 ${ATFW_OPT_LOSSY}"
ATFW_OPT_r8a7796 = "LSI=M3 RCAR_DRAM_SPLIT=2 ${ATFW_OPT_LOSSY}"
-ATFW_OPT_append_ulcb = " RCAR_GEN3_ULCB=1"
+ATFW_OPT_append_ulcb = " RCAR_GEN3_ULCB=1 PMIC_LEVEL_MODE=0"
# requires CROSS_COMPILE set by hand as there is no configure script
export CROSS_COMPILE="${TARGET_PREFIX}"