aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThao Nguyen <thao.nguyen.yb@rvc.renesas.com>2017-04-17 09:56:20 +0700
committerKhiem Nguyen <khiem.nguyen.xt@renesas.com>2017-04-19 09:56:54 +0700
commita12483ddadd6263e424dca64adef7861b04d8604 (patch)
treea4d8368a8bf5d513973ab080fc86ba3576e8654f
parent4979e05406c77524cf90b308ce4bf2a72032ee65 (diff)
rcar-gen3: linux-renesas: Upgrade Linux BSP to v3.5.3
This commit upgrades Linux BSP to v3.5.3 and adds device tree file for M3 Salvator-XS board to salvator-x.conf. Linux BSP to v3.5.3 updates following items: Kernel core - Add workaround for PRR register of R-Car M3 WS1.1. (Fix printing cpu info.) - Add device tree file for Salvator-XS board with R-Car M3. - Fix R-Car M3 Salvator-X device tree file for MIX function of Audio driver. Power Management - Mark the OPP to be used during system suspend. - Enable CPUIdle function. - Apply new CPUIdle parameters. Audio driver - Confirm this driver can resume with Suspend to RAM during capture. - Avoid SSI_MODEx settings for SSI8. - Clear DE bit only in PDMACHCR when it stops. - Tidyup Audio-DMAC channel for DVC. - Enable PCM RATE until 192000. - Fix the setting of saved_rate during the resume process. Display driver - Fix the problem that the flicker may occur during rendering by the application. - Add brs option check for VGA connector. - Add routing set for digital RGB previously. DMA Engine driver - Fix release resources after interrupt process. Ethernet driver - Add phy-reset-gpios. This driver can work after Suspend to RAM with Salvator-XS board. - Fix GIS_PTMF bit clearing in ravb_ptp_interrupt. I2C driver - Revert and fix about unnecessary function related to Suspend to RAM. MSIOF driver - Fix SPI division value setting of R-Car M3 based on hardware specification. - Allow interrupts during msiof slave mode transfer wait. - Revert and fix about unnecessary function related to Suspend to RAM. RWDT driver - Fix timeout count calculation. SCIF/HSCIF driver - Fix panic when serial console and DMA are enabled. - Revert about unnecessary function related to Suspend to RAM. SD/MMC driver - Wait for CBSY instead of SCLKDIVEN. - Add re-tuning condition. - Add internal DMAC reset at startup. - Add the driver strength setting. eMMC HS400 mode can work with R-Car M3 WS1.1 on Salvator-XS board. Thermal driver - Fix to support thermal for both M3 WS1.0 and WS1.1. Video Capture driver - Fix resuming procedure. - Fix first field detection control. - Fix 720x480p transfer rate. - Fix video standard selection register setting. Change-Id: I3b0d6237c9d0c56a9f2870f1fde89ea215f163cd Signed-off-by: Thao Nguyen <thao.nguyen.yb@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/conf/machine/salvator-x.conf5
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb4
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb4
3 files changed, 8 insertions, 5 deletions
diff --git a/meta-rcar-gen3/conf/machine/salvator-x.conf b/meta-rcar-gen3/conf/machine/salvator-x.conf
index 59e4469..48e8b8f 100644
--- a/meta-rcar-gen3/conf/machine/salvator-x.conf
+++ b/meta-rcar-gen3/conf/machine/salvator-x.conf
@@ -28,7 +28,10 @@ KERNEL_DEVICETREE_r8a7795 = " \
renesas/r8a7795-salvator-xs.dtb \
"
# Device tree for M3
-KERNEL_DEVICETREE_r8a7796 = "renesas/r8a7796-salvator-x.dtb"
+KERNEL_DEVICETREE_r8a7796 = " \
+ renesas/r8a7796-salvator-x.dtb \
+ renesas/r8a7796-salvator-xs.dtb \
+"
# Configuration for ARM Trusted Firmware
EXTRA_IMAGEDEPENDS += " arm-trusted-firmware optee-os"
diff --git a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb
index e9b27e3..2b4e241 100644
--- a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb
@@ -2,8 +2,8 @@ require recipes-kernel/linux-libc-headers/linux-libc-headers.inc
RENESAS_BSP_URL = " \
git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.9/rcar-3.5.2"
-SRCREV = "d4f12792cd97457e13ea4a77b4aa9fb3c28875fe"
+BRANCH = "v4.9/rcar-3.5.3"
+SRCREV = "098ccf1c9b89109f63fef6d1f6294b29bb5cafba"
SRC_URI = "${RENESAS_BSP_URL};branch=${BRANCH}"
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb
index eb25dba..ed51dcf 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb
@@ -7,8 +7,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb"
RENESAS_BSP_URL = "git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.9/rcar-3.5.2"
-SRCREV = "d4f12792cd97457e13ea4a77b4aa9fb3c28875fe"
+BRANCH = "v4.9/rcar-3.5.3"
+SRCREV = "098ccf1c9b89109f63fef6d1f6294b29bb5cafba"
SRC_URI = "${RENESAS_BSP_URL};protocol=git;nocheckout=1;branch=${BRANCH}"