aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2020-04-16 09:56:17 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-04-28 16:03:54 +0200
commit7665ca80c23983891811bbeb187297725e2fe92f (patch)
treea783f177212a6c94e46e8824c2d4ecae4ff5e254
parent94ced80e7fa92664fa2d1af690486f57b9fcbf17 (diff)
[AGL] TMP fix on gstreamer1.0-omx
- Don't merge it upstream! Bug-AGL: SPEC-3328 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh> Change-Id: I6f396f98616fb60b8033e282ed8512c355b14113
-rw-r--r--meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx/fix_meson_build.diff27
-rw-r--r--meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.%.bbappend28
2 files changed, 42 insertions, 13 deletions
diff --git a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx/fix_meson_build.diff b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx/fix_meson_build.diff
new file mode 100644
index 0000000..040a956
--- /dev/null
+++ b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx/fix_meson_build.diff
@@ -0,0 +1,27 @@
+diff --git a/meson.build b/meson.build
+index cdd6d17..78e8f40 100644
+--- a/meson.build
++++ b/meson.build
+@@ -212,6 +212,9 @@ elif omx_target == 'tizonia'
+ cdata.set('TIZONIA_LIBDIR', tizil_dep.get_pkgconfig_variable('libdir'))
+ tizil_includedir = tizil_dep.get_pkgconfig_variable('includedir')
+ gst_omx_args += ['-I' + tizil_includedir + '/tizonia']
++elif omx_target == 'rcar'
++ cdata.set('USE_OMX_TARGET_RCAR', 1)
++ cdata.set('USE_RCAR_DMABUF', 1)
+ else
+ error ('Unsupported omx target specified. Use the -Dtarget option')
+ endif
+diff --git a/meson_options.txt b/meson_options.txt
+index 75985ce..c0d32d9 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,7 +1,7 @@
+ option('header_path', type : 'string', value : '',
+ description : 'An extra include directory to find the OpenMax headers')
+ option('target', type : 'combo',
+- choices : ['none', 'generic', 'rpi', 'bellagio', 'tizonia', 'zynqultrascaleplus'], value : 'none',
++ choices : ['none', 'generic', 'rpi', 'bellagio', 'tizonia', 'zynqultrascaleplus', 'rcar'], value : 'none',
+ description : 'The OMX platform to target')
+ option('struct_packing', type : 'combo',
+ choices : ['0', '1', '2', '4', '8'], value : '0',
diff --git a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.%.bbappend b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.%.bbappend
index 5f1fd82..e7a08c4 100644
--- a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.%.bbappend
+++ b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.%.bbappend
@@ -1,34 +1,36 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
-SRC_URI_remove = "http://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${PV}.tar.xz"
+SRC_URI_remove = "https://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${PV}.tar.xz"
SRC_URI_append = " \
- gitsm://github.com/renesas-rcar/gst-omx.git;branch=RCAR-GEN3/1.16.0 \
+ gitsm://github.com/iotbzh/gst-omx.git;branch=RCAR-GEN3/1.16.2 \
file://gstomx.conf \
"
+# file://fix_meson_build.diff
+
require include/rcar-gen3-path-common.inc
DEPENDS += "omx-user-module mmngrbuf-user-module"
-SRCREV = "e9a197cdb078f36d37fcb8ada868d5352ade2f77"
+#SRCREV = "4b4d3b4e7682e1c80c0c94f1b997b815a3e7740b"
+SRCREV = "476814f3f19902f919bd86ae880bce0e50984900"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
- file://omx/gstomx.h;beginline=1;endline=22;md5=e2c6664eda77dc22095adbed9cb6c6e4 \
+ file://omx/gstomx.h;beginline=1;endline=22;md5=d411057db0aa43d31f1ec9d6a980a216 \
"
S = "${WORKDIR}/git"
-GSTREAMER_1_0_OMX_TARGET = "rcar"
+#GSTREAMER_1_0_OMX_TARGET = "rcar"
GSTREAMER_1_0_OMX_CORE_NAME = "${libdir}/libomxr_core.so"
EXTRA_OECONF_append = " --enable-experimental"
-do_configure_prepend() {
- cd ${S}
- install -m 0644 ${WORKDIR}/gstomx.conf ${S}/config/rcar/
- sed -i 's,@RENESAS_DATADIR@,${RENESAS_DATADIR},g' ${S}/config/rcar/gstomx.conf
- ./autogen.sh --noconfigure
- cd ${B}
+python __anonymous () {
+ d.appendVar("CFLAGS", " -I${S}/omx/openmax")
+ d.appendVar("CFLAGS", " -I${S}/omx")
}
-RDEPENDS_${PN}_append = " omx-user-module"
-RDEPENDS_${PN}_remove = "libomxil"
+
+
+VIRTUAL-RUNTIME_libomxil = "omx-user-module"
+