aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAymeric Aillet <aymeric.aillet@iot.bzh>2019-09-20 16:40:28 +0200
committerRonan Le Martret <ronan.lemartret@iot.bzh>2020-02-07 11:36:36 +0100
commitd10c948ac8124abc19b4d042a61bd861b1543add (patch)
tree45da6fe2e91df2a80a7575345fd550ac0828458a
parent51006db5030d4d2ff76564cd0a16bc26238ba03d (diff)
[Community] Optee_os recipe modification
In order to build trusted applications from the official optee sources we need files that weren't built with the current version of the recipe. This modification allow us to build trusted applications in the AGL environment. BUG-AGL: SPEC-2848 Change-Id: Ic34121428abbaf316656519f71d876abfc1f95d5 Signed-off-by: Aymeric Aillet <aymeric.aillet@iot.bzh>
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
index 553174b..767ce2e 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
@@ -53,8 +53,10 @@ do_compile() {
oe_runmake PLATFORM=${PLATFORM} CFG_ARM64_core=y
}
-# do_install() nothing
-do_install[noexec] = "1"
+do_install() {
+ install -d ${D}/usr/share/optee
+ cp -r ${S}/out/arm-plat-${PLATFORM}/export-ta_arm64 ${D}/usr/share/optee
+}
do_deploy() {
# Create deploy folder
@@ -66,3 +68,6 @@ do_deploy() {
install -m 0644 ${S}/out/arm-plat-${PLATFORM}/core/tee.srec ${DEPLOYDIR}/tee-${MACHINE}.srec
}
addtask deploy before do_build after do_compile
+
+FILES_${PN}-staticdev += "${datadir}/optee/export-ta_arm64/lib/*.a"
+FILES_${PN}-dev += "${datadir}/optee/export-ta_arm64"