aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThao Nguyen <thao.nguyen.yb@renesas.com>2017-05-17 16:15:42 +0700
committerThao Nguyen <thao.nguyen.yb@renesas.com>2017-06-21 10:53:06 +0700
commit2cd35b4cb9256aca173978573311b542395f6cce (patch)
tree8a0da4a6c14d3aedd4b50c1f2d7070d9e87196a0
parent7405103ef44eae2b0d8d1ff66f88106e770de210 (diff)
rcar-gen3: gstreamer1.0-omx: Fix issue downloading from HTTP/HTTPS proxy
This issue exists in some special environment. Submodule can not be downloaded, because HTTP/HTTPS lose their values during configure state. Temporary solution is exporting those values in configure state. Signed-off-by: Thao Nguyen <thao.nguyen.yb@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.2.0.bbappend4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.2.0.bbappend b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.2.0.bbappend
index 7d90891..9fd8bf8 100644
--- a/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.2.0.bbappend
+++ b/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.2.0.bbappend
@@ -16,6 +16,10 @@ EXTRA_OECONF_append = " --enable-experimental"
EXTRA_OECONF_append = " --with-omx-header-path=${S}/omx/openmax"
do_configure_prepend() {
+ export http_proxy=${http_proxy}
+ export https_proxy=${https_proxy}
+ export HTTP_PROXY=${HTTP_PROXY}
+ export HTTPS_PROXY=${HTTPS_PROXY}
cd ${S}
./autogen.sh --noconfigure
cd ${B}