aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Lawrence <stephen.lawrence@renesas.com>2017-04-21 14:44:55 +0100
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-09-13 15:40:30 +0200
commit4b1967cd356cc371723cf2702df3c4c20b87ff14 (patch)
tree72d52b88acadfd1e3922ea092ee9fbf23c07051d
parent52a5df36b4cd2ca0f5ec8eab9446f4f128ef727c (diff)
u-boot: adapt to change in build directory in morty
In YP 2.2 (Morty) {B} is no longer the default working directory for tasks [1]. Adapt the deploy task so it finds the srec. [1] http://www.yoctoproject.org/docs/2.2.1/ref-manual/ref-manual.html#migration-2.2-B-no-longer-default-working-directory-for-tasks (cherry picked from commit 08383820f1b5b7a39be5f9e47925026abeb26463) Signed-off-by: Stephen Lawrence <stephen.lawrence@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb
index 5af3632..e92a6b5 100644
--- a/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb
+++ b/meta-rcar-gen3/recipes-bsp/u-boot/u-boot_2015.04.bb
@@ -19,7 +19,7 @@ UBOOT_SREC_IMAGE ?= "u-boot-elf-${MACHINE}-${PV}-${PR}.srec"
UBOOT_SREC_SYMLINK ?= "u-boot-elf-${MACHINE}.srec"
do_deploy_append() {
- install -m 644 ${S}/${UBOOT_SREC} ${DEPLOYDIR}/${UBOOT_SREC_IMAGE}
+ install -m 644 ${B}/${UBOOT_SREC} ${DEPLOYDIR}/${UBOOT_SREC_IMAGE}
cd ${DEPLOYDIR}
rm -f ${UBOOT_SREC} ${UBOOT_SREC_SYMLINK}
ln -sf ${UBOOT_SREC_IMAGE} ${UBOOT_SREC_SYMLINK}