aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThao Nguyen <thao.nguyen.yb@renesas.com>2017-07-15 18:35:07 +0700
committerThao Nguyen <thao.nguyen.yb@renesas.com>2017-08-25 08:45:32 +0700
commit52a5df36b4cd2ca0f5ec8eab9446f4f128ef727c (patch)
tree878ea1d298a6f061818e0646df533d2cb9f7e02e
parentf8e997803ce1f4af660bf527e8a47805af440baf (diff)
rcar-gen3: packagegroup: Create new packagegroups for GFX packagesRenesas-Yocto-v2.23.0
This commit modifies recipes to define 3 packagegroups for graphic. There are 3 type packagegroups which are provided into IMAGE_INSTALL: - packagegroup-wayland-community: contains wayland/weston/alsa/libdrm components. - packagegroup-graphics-renesas-proprietary: contains Renesas GFX are kernel-module-gles and gles-user-module. - packagegroup-graphics-renesas-wayland: contains Renesas Wayland components: libgbm, libgbm-dev, wayland-kms. This patch also removes the definition for 32bit packages, because 32bit env has been stopped supporting. Signed-off-by: Thao Nguyen <thao.nguyen.yb@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-graphics/images/core-image-weston.inc33
-rw-r--r--meta-rcar-gen3/recipes-graphics/packagegroups/packagegroup-graphic-renesas.bb37
2 files changed, 40 insertions, 30 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/images/core-image-weston.inc b/meta-rcar-gen3/recipes-graphics/images/core-image-weston.inc
index 28e28d4..eb4f1b8 100644
--- a/meta-rcar-gen3/recipes-graphics/images/core-image-weston.inc
+++ b/meta-rcar-gen3/recipes-graphics/images/core-image-weston.inc
@@ -1,42 +1,15 @@
require include/gles-control.inc
require core-image-renesas-mmp-base.inc
-# Wayland basic packages
-WAYLAND_BASE_PKGS = " \
- weston-bin \
- alsa-utils \
- alsa-tools \
- libdrm-tests \
- libdrm-kms \
-"
-
-# GFX for Wayland packages
-WAYLAND_GLES_PKGS = "libgbm-dev"
-
-# GFX driver and library packages
-GLES_PKGS = " \
- kernel-module-gles \
- gles-user-module \
-"
-
# Gstreamer Packages
GSTREAMER_PKGS = "packagegroup-gstreamer1.0-plugins"
-# 32bit packages for wayland env
-WAYLAND_32BIT_PKGS = " \
- lib32-weston \
- lib32-libdrm \
- lib32-libdrm-kms \
- ${@base_conditional("USE_GLES", "1", "lib32-gles-user-module", "", d)} \
-"
-
# Install packages for Wayland Env
# default: Basic packages, Gstreamer packages
# optional: GFX packages
IMAGE_INSTALL_append = " \
- ${WAYLAND_BASE_PKGS} \
${GSTREAMER_PKGS} \
- ${@base_conditional("USE_GLES", "1", "${GLES_PKGS}", "", d)} \
- ${@base_conditional("USE_GLES_WAYLAND", "1", "${WAYLAND_GLES_PKGS}", "", d)} \
- ${@base_conditional("USE_32BIT_WAYLAND", "1", "${WAYLAND_32BIT_PKGS}", "", d)} \
+ packagegroup-wayland-community \
+ packagegroup-graphics-renesas-proprietary \
+ packagegroup-graphics-renesas-wayland \
"
diff --git a/meta-rcar-gen3/recipes-graphics/packagegroups/packagegroup-graphic-renesas.bb b/meta-rcar-gen3/recipes-graphics/packagegroups/packagegroup-graphic-renesas.bb
new file mode 100644
index 0000000..19e165e
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/packagegroups/packagegroup-graphic-renesas.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Renesas package group for Weston"
+LICENSE = "CLOSED & MIT"
+
+inherit packagegroup
+require include/gles-control.inc
+
+PACKAGES = " \
+ packagegroup-wayland-community \
+ packagegroup-graphics-renesas-proprietary \
+ packagegroup-graphics-renesas-wayland \
+"
+
+PR = "r0"
+
+RDEPENDS_packagegroup-wayland-community = " \
+ wayland \
+ weston \
+ weston-bin \
+ alsa-utils \
+ alsa-tools \
+ libdrm-tests \
+ libdrm-kms \
+"
+
+RDEPENDS_packagegroup-graphics-renesas-proprietary = " \
+ ${@bb.utils.contains('USE_GLES', '1', \
+ 'kernel-module-gles gles-user-module' , \
+ '', d)} \
+"
+
+DEPENDS_packagegroup-graphics-renesas-wayland = "libegl"
+
+RDEPENDS_packagegroup-graphics-renesas-wayland = " \
+ ${@bb.utils.contains('USE_GLES_WAYLAND', '1', \
+ 'libgbm libgbm-dev wayland-kms', \
+ '', d)} \
+"