aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-03-29 15:12:49 +0200
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-09-15 10:20:15 +0200
commit6ada9672cb85b9b9b48285c74671c6368243e626 (patch)
tree1c582d08c55f839785e80658909e94d50aa24205
parent48f2ee2ab8beee5fe884a887e258518a6be87294 (diff)
[COMMUNITY] add depends on mesa to gles-user-module
the populate_sysroot of gles-user-module must depends on the populate_sysroot of the virtual/mesa, because header from gles-user-module depends on the header from virtual/mesa. Change-Id: I8368bba6a19ca628a3496a3eebbc18a3c41c322d Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
index 450080b..aaff2bb 100644
--- a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
@@ -28,6 +28,9 @@ SYSTEMD_SERVICE_${PN} = "rc.pvr.service"
do_populate_lic[noexec] = "1"
do_compile[noexec] = "1"
+#The headers of gles-user-module need headers from virtual/mesa.
+do_populate_sysroot[depends] += "virtual/mesa:do_populate_sysroot"
+
do_install() {
# Install configuration files
install -d ${D}/${sysconfdir}/init.d