aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Lawrence <stephen.lawrence@renesas.com>2017-05-18 14:07:31 +0100
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-09-13 15:40:30 +0200
commitf16dbb642b391ded5d4d436171d2e9a09b4e9d86 (patch)
treebdf0a2c6e85c65b199ba8904f0c7064db3bcf1fc
parent8675c1fecbf79774e7f4141dbb17aaf86979cb7b (diff)
gles-user-module: fix occasional qtbase configure build issue
Building the meta-qt5 component qtbase occasionally failures in the do_configure() task with the error: make: *** [opengles2] Error 1 OpenGL ES 2.0 disabled. The OpenGL ES 2.0 functionality test failed! This is a build order problem caused by an incomplete build dependency chain. Linking opengles2 against libIMGegl.so (the virtual/libgles2 provider) has a dependency on libgbm.so and libwayland-kms.so so they must be built first. qtbase does not have many gfx components in its build depedency list and therefore may build earlier, which in turn results in the error. Simply adding libgbm and wayland-kms to the gles-user-module DEPENDS results in a circular build depedency. This is a workaround to the problem whilst the build depdency issue is resolved. For it to work add packagegroup-graphics-libegl to your IMAGE_INSTALL. This fixes the qtbase do_configure() build error reported in GDP-590 [1]. [1] https://at.projects.genivi.org/jira/browse/GDP-590 (cherry picked from commit 4ebc763eb413ef9a041cb83761d530f865764e74) Signed-off-by: Stephen Lawrence <stephen.lawrence@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb2
-rw-r--r--meta-rcar-gen3/recipes-graphics/packagegroups/packagegroup-graphics-libegl.bb25
2 files changed, 26 insertions, 1 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
index e66164f..450080b 100644
--- a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
@@ -98,7 +98,7 @@ FILES_${PN}-dev = " \
${libdir}/pkgconfig/* \
"
-PROVIDES = "virtual/libgles2 virtual/egl"
+PROVIDES = "virtual/libgles2"
RPROVIDES_${PN} += " \
${GLES}-user-module \
libgles2-mesa \
diff --git a/meta-rcar-gen3/recipes-graphics/packagegroups/packagegroup-graphics-libegl.bb b/meta-rcar-gen3/recipes-graphics/packagegroups/packagegroup-graphics-libegl.bb
new file mode 100644
index 0000000..35bfd37
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/packagegroups/packagegroup-graphics-libegl.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Graphics OpenGL ES user libraries and depenencies package group"
+LICENSE = "CLOSED & MIT"
+
+DEPENDS = "gles-user-module \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'libgbm wayland-kms', '', d)} \
+"
+
+PR = "r0"
+
+inherit packagegroup
+
+PACKAGES = " \
+ packagegroup-graphics-libegl \
+"
+
+RDEPENDS_packagegroup-graphics-libegl = " \
+ gles-user-module \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'libgbm wayland-kms', '', d)} \
+"
+
+PROVIDES = "virtual/egl"
+RPROVIDES_${PN} += " \
+ libegl \
+ libegl1 \
+"