aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThao Nguyen <thao.nguyen.yb@renesas.com>2017-06-21 08:03:10 +0700
committerThao Nguyen <thao.nguyen.yb@renesas.com>2017-06-21 10:53:05 +0700
commitf70462150453865982dced0edd31fd7c1385f538 (patch)
treee1a3d3059c66eca51b3f3d9a2558c1a203167582
parent95cb48ba09bc7e55fd549817e3e26723409e68d5 (diff)
rcar-gen3: linux-renesas: Update BSP to v3.5.5
This commit updates Linux BSP from v3.5.3 to v3.5.5 for following items: Kernel core - Add ZG clock divider support. - Revert and fix about Suspend to RAM. - Add DEVFREQ support for GSX. - Add usb companion property in EHCI. - Add USB3.0 peripheral device node. - Use IPMMU(MMU mode) for IPMMU-VP and IPMMU-VC0/1 with R-Car H3 Ver.1.x, for IPMMU-VP0/1 and IPMMU-VC0/1 with R-Car H3 Ver.2.0, in IPMMUVC0 with R-Car M3. - Add override support for the actual number of MMU contexts. - Fix audio Mix support on DTSI. Power Management - Cleanup AVS driver. - Update voltage for VDD_DVFS and VDD. Audio driver - Resolve 16bit/24bit capture noise problem by enabling clock-frequency for both 4.1kHz/48kHz and fixing possible NULL pointer dereference. - Resolve playback problem of sampling rate 32kHz, 176.4kHz and 192kHz by enabling clock-frequency for both 44.1kHz/48kHz. - Resolve “can’t get dma channel” error at the time of unbind/bind by fixing up of_clk_add_provider() usage for multi clkout and calling the missing of_clk_del_provider() when removing. - Resolve 48kHz audio 1-20k sweep noise problem by enabling clock-frequency 44.1kHz/48kHz. - Merge rsnd_kctrl_new_m/s/e into rsnd_kctrl_new(). - Fix 24bit capture noise problem by not using PDTA bit for 24bit on SSI. - Request/Release DMA channel each time for avoiding error of getting dma channel. Display driver - Use dma_map_sg_attrs to skip synchronization of the CPU cache. - Add mode_fixup callback function. - Control clock of bridge during S2RAM and change to control clock via clock driver. - Fix reserved register setting for R-Car for H/W manual update. - Add null pointer check for brs option. - Revert "drm: bridge/dw-hdmi: Add HDP interrupt disable for suspend". - Fix hierarchy of driver structure for clk-5p49x. DMA Engine driver - Revert dma pause function because it was rejected by upstream. GPIO driver - Revert and fix about Suspend to RAM. - Add GP-1-28 port pin support for R-Car H3 Ver.2.0 because of H/W manual updating to Rev.0.54E. Modify just PFC and DT. SCIF/HSCIF driver - Resolve system freezing. SD/MMC driver - Add initial setting of interrupt mask register. - Fix command sequence at error detection. - Fix “Wait for CBSY instead of SCLKDIVEN”. - Fix processing when detecting SCC error and fix error handling when issuing CMD23. - Fix reset_hs400_mode. - Fix problem that SDIO interrupt may be missed. USB3.0 Function - Add Role-change support. - Add DMA support. - Add basic function support. USB2.0 Host driver - Fix mouse connection time (2 second or more) when resuming. USB3.0 Host driver - Support for R-Car Gen3 USB 3.0 PHY for SSC function. - Add R-Car Gen3 USB 2.0 clock selector PHY, support for R-Car Gen3 USB 3.0 PHY. Video Capture driver - Add 2 lane support with rcar-csi2.c. - Fix image alignment for setting pre clipping. - Fix wait time for software reset in rcar-csi2.c because of H/W manual updating to Rev.0.54E. - Fix PHY initialization in rcar-csi2.c because of H/W manual updating to Rev.0.54E. - Fix PHTW register setting in rcar-csi2.c because of H/W manual updating toRev.0.54E. - Fix wait procedure usleep_range from msleep in adv7482.c. - Fix channel get procedure. Signed-off-by: Thao Nguyen <thao.nguyen.yb@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb4
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig24
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb4
3 files changed, 26 insertions, 6 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb
index 2b4e241..81a70b8 100644
--- a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb
@@ -2,8 +2,8 @@ require recipes-kernel/linux-libc-headers/linux-libc-headers.inc
RENESAS_BSP_URL = " \
git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.9/rcar-3.5.3"
-SRCREV = "098ccf1c9b89109f63fef6d1f6294b29bb5cafba"
+BRANCH = "v4.9/rcar-3.5.5"
+SRCREV = "58e9b7349e1a28f2ef830f9164112fb17ba31426"
SRC_URI = "${RENESAS_BSP_URL};branch=${BRANCH}"
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
index 7c8b7d5..63c00c8 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
@@ -2675,6 +2675,7 @@ CONFIG_THERMAL_DEFAULT_GOV_POWER_ALLOCATOR=y
CONFIG_THERMAL_GOV_POWER_ALLOCATOR=y
CONFIG_CPU_THERMAL=y
# CONFIG_CLOCK_THERMAL is not set
+# CONFIG_DEVFREQ_THERMAL is not set
CONFIG_THERMAL_EMULATION=y
# CONFIG_HISI_THERMAL is not set
# CONFIG_MAX77620_THERMAL is not set
@@ -4060,7 +4061,7 @@ CONFIG_USB_GADGET_STORAGE_NUM_BUFFERS=2
# CONFIG_USB_GR_UDC is not set
# CONFIG_USB_R8A66597 is not set
CONFIG_USB_RENESAS_USBHS_UDC=y
-# CONFIG_USB_RENESAS_USB3 is not set
+CONFIG_USB_RENESAS_USB3=y
# CONFIG_USB_PXA27X is not set
# CONFIG_USB_MV_UDC is not set
# CONFIG_USB_MV_U3D is not set
@@ -4130,6 +4131,7 @@ CONFIG_MMC_SPI=y
CONFIG_MMC_TMIO_CORE=y
CONFIG_MMC_SDHI=y
# CONFIG_MMC_SDHI_PIO is not set
+# CONFIG_MMC_SDHI_SEQ_WORKAROUND is not set
# CONFIG_MMC_CB710 is not set
# CONFIG_MMC_VIA_SDMMC is not set
CONFIG_MMC_DW=y
@@ -4582,7 +4584,23 @@ CONFIG_ARCH_TEGRA_210_SOC=y
# CONFIG_SOC_TI is not set
CONFIG_RCAR_THERMAL_EMS_ENABLED=y
CONFIG_RCAR_DDR_BACKUP=y
-# CONFIG_PM_DEVFREQ is not set
+CONFIG_PM_DEVFREQ=y
+
+#
+# DEVFREQ Governors
+#
+CONFIG_DEVFREQ_GOV_SIMPLE_ONDEMAND=y
+CONFIG_DEVFREQ_GOV_PERFORMANCE=y
+CONFIG_DEVFREQ_GOV_POWERSAVE=y
+CONFIG_DEVFREQ_GOV_USERSPACE=y
+CONFIG_DEVFREQ_GOV_PASSIVE=y
+
+#
+# DEVFREQ Drivers
+#
+# CONFIG_ARM_EXYNOS_BUS_DEVFREQ is not set
+# CONFIG_ARM_RK3399_DMC_DEVFREQ is not set
+# CONFIG_PM_DEVFREQ_EVENT is not set
CONFIG_EXTCON=y
#
@@ -4927,6 +4945,8 @@ CONFIG_PHY_EXYNOS_MIPI_VIDEO=y
# CONFIG_PHY_PXA_28NM_USB2 is not set
# CONFIG_PHY_RCAR_GEN2 is not set
CONFIG_PHY_RCAR_GEN3_USB2=y
+# CONFIG_PHY_RCAR_GEN3_USB2_CLKSEL is not set
+# CONFIG_PHY_RCAR_GEN3_USB3 is not set
CONFIG_PHY_EXYNOS_DP_VIDEO=y
# CONFIG_BCM_KONA_USB2_PHY is not set
# CONFIG_PHY_MT65XX_USB3 is not set
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb
index ed51dcf..88a963f 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb
@@ -7,8 +7,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb"
RENESAS_BSP_URL = "git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.9/rcar-3.5.3"
-SRCREV = "098ccf1c9b89109f63fef6d1f6294b29bb5cafba"
+BRANCH = "v4.9/rcar-3.5.5"
+SRCREV = "58e9b7349e1a28f2ef830f9164112fb17ba31426"
SRC_URI = "${RENESAS_BSP_URL};protocol=git;nocheckout=1;branch=${BRANCH}"