aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThao Nguyen <thao.nguyen.yb@renesas.com>2017-07-18 15:45:28 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2018-01-30 10:00:50 +0700
commit12e83a2162d0b3dfea874042d395a48fd798a19f (patch)
tree81614210a956e300c96dc80e6d6feb3f1d1dd79d
parent6bafe741c94ca9ef335ec175ed2c85c624a49bc3 (diff)
rcar-gen3: libdrm: Change to use v2.4.85
mesa v17.1.1 only supports libdrm from 2.4.75 and later, so we set PREFERRED_VERSION_libdrm in board config to use libdrm v2.4.85 from poky to prevent configure error. | checking for libdrm >= 2.4.75... no | checking for glproto >= 1.4.14... yes | configure: error: Direct rendering requires libdrm >= 2.4.75 | NOTE: The following config.log files may provide further information. | NOTE: /build/tmp/work/aarch64-poky-linux/mesa/2_17.1.1-r0/build/config.log | ERROR: configure failed Signed-off-by: Thao Nguyen <thao.nguyen.yb@renesas.com> Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/conf/machine/h3ulcb.conf2
-rw-r--r--meta-rcar-gen3/conf/machine/m3ulcb.conf2
-rw-r--r--meta-rcar-gen3/conf/machine/salvator-x.conf2
-rw-r--r--meta-rcar-gen3/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch56
-rw-r--r--meta-rcar-gen3/recipes-graphics/drm/libdrm/fix_O_CLOEXEC_undeclared.patch2
-rw-r--r--meta-rcar-gen3/recipes-graphics/drm/libdrm/installtests.patch28
-rw-r--r--meta-rcar-gen3/recipes-graphics/drm/libdrm_2.4.85.bb (renamed from meta-rcar-gen3/recipes-graphics/drm/libdrm_2.4.68.bb)20
7 files changed, 92 insertions, 20 deletions
diff --git a/meta-rcar-gen3/conf/machine/h3ulcb.conf b/meta-rcar-gen3/conf/machine/h3ulcb.conf
index a24c221..69e0d41 100644
--- a/meta-rcar-gen3/conf/machine/h3ulcb.conf
+++ b/meta-rcar-gen3/conf/machine/h3ulcb.conf
@@ -37,7 +37,7 @@ EXTRA_IMAGEDEPENDS += " u-boot"
UBOOT_MACHINE = "h3ulcb_defconfig"
# libdrm
-PREFERRED_VERSION_libdrm = "2.4.68"
+PREFERRED_VERSION_libdrm = "2.4.85"
# Add variable to Build Configuration in build log
BUILDCFG_VARS_append = " SOC_FAMILY"
diff --git a/meta-rcar-gen3/conf/machine/m3ulcb.conf b/meta-rcar-gen3/conf/machine/m3ulcb.conf
index f8d74ec..8c08deb 100644
--- a/meta-rcar-gen3/conf/machine/m3ulcb.conf
+++ b/meta-rcar-gen3/conf/machine/m3ulcb.conf
@@ -34,7 +34,7 @@ EXTRA_IMAGEDEPENDS += " u-boot"
UBOOT_MACHINE = "m3ulcb_defconfig"
# libdrm
-PREFERRED_VERSION_libdrm = "2.4.68"
+PREFERRED_VERSION_libdrm = "2.4.85"
# Add variable to Build Configuration in build log
BUILDCFG_VARS_append = " SOC_FAMILY"
diff --git a/meta-rcar-gen3/conf/machine/salvator-x.conf b/meta-rcar-gen3/conf/machine/salvator-x.conf
index f32ce7c..981062d 100644
--- a/meta-rcar-gen3/conf/machine/salvator-x.conf
+++ b/meta-rcar-gen3/conf/machine/salvator-x.conf
@@ -60,7 +60,7 @@ UBOOT_MACHINE_r8a7796 = "r8a7796_salvator-x_defconfig"
UBOOT_MACHINE_r8a77965 = "r8a77965_salvator-x_defconfig"
# libdrm
-PREFERRED_VERSION_libdrm = "2.4.68"
+PREFERRED_VERSION_libdrm = "2.4.85"
# Add variable to Build Configuration in build log
BUILDCFG_VARS_append = " SOC_FAMILY"
diff --git a/meta-rcar-gen3/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch b/meta-rcar-gen3/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch
new file mode 100644
index 0000000..bf52637
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/drm/libdrm/0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch
@@ -0,0 +1,56 @@
+From e6bd4205b0b546afe991ae6f72256645f4404ad4 Mon Sep 17 00:00:00 2001
+From: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Date: Mon, 5 Sep 2016 14:41:37 +0300
+Subject: [PATCH libdrm] configure.ac: Allow explicit enabling of cunit tests
+
+Add --with-cunit to make it easier to do reproducible builds. Default
+is still to probe cunit and build opportunistically.
+
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Upstream-Status: Submitted [mailing list]
+---
+ configure.ac | 14 ++++++++++++--
+ 1 file changed, 12 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index e3048c7..918d21d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -137,6 +137,12 @@ AC_ARG_ENABLE(install-test-programs,
+ [Install test programs (default: no)]),
+ [INSTALL_TESTS=$enableval], [INSTALL_TESTS=no])
+
++AC_ARG_WITH([cunit],
++ [AS_HELP_STRING([--with-cunit],
++ [Build tests that use cunit (default: auto)])],
++ [],
++ [with_cunit=auto])
++
+ dnl ===========================================================================
+ dnl check compiler flags
+ AC_DEFUN([LIBDRM_CC_TRY_FLAG], [
+@@ -372,7 +378,7 @@ if test "x$RADEON" = xyes; then
+ AC_DEFINE(HAVE_RADEON, 1, [Have radeon support])
+ fi
+
+-if test "x$AMDGPU" != xno; then
++if test "x$with_cunit" != xno -a "x$AMDGPU" != xno; then
+ # Detect cunit library
+ PKG_CHECK_MODULES([CUNIT], [cunit >= 2.1], [have_cunit=yes], [have_cunit=no])
+ # If pkg-config does not find cunit, check it using AC_CHECK_LIB. We
+@@ -399,7 +406,11 @@ if test "x$AMDGPU" = xyes; then
+ AC_DEFINE(HAVE_CUNIT, [test "x$have_cunit" != "xno"], [Enable CUNIT Have amdgpu support])
+
+ if test "x$have_cunit" = "xno"; then
+- AC_MSG_WARN([Could not find cunit library. Disabling amdgpu tests])
++ if test "x$with_cunit" = "xyes"; then
++ AC_MSG_ERROR([Could not find cunit library but --with-cunit was given])
++ elif test "x$with_cunit" = "xauto"; then
++ AC_MSG_WARN([Could not find cunit library. Disabling amdgpu tests])
++ fi
+ fi
+ fi
+
+--
+2.1.4
+
diff --git a/meta-rcar-gen3/recipes-graphics/drm/libdrm/fix_O_CLOEXEC_undeclared.patch b/meta-rcar-gen3/recipes-graphics/drm/libdrm/fix_O_CLOEXEC_undeclared.patch
index 286e548..4708bf1 100644
--- a/meta-rcar-gen3/recipes-graphics/drm/libdrm/fix_O_CLOEXEC_undeclared.patch
+++ b/meta-rcar-gen3/recipes-graphics/drm/libdrm/fix_O_CLOEXEC_undeclared.patch
@@ -19,6 +19,6 @@ diff -Naur libdrm-2.4.66-orig/tests/drmdevice.c libdrm-2.4.66/tests/drmdevice.c
*/
+#include <config.h>
+ #include <errno.h>
#include <stdio.h>
#include <stdlib.h>
- #include <sys/stat.h>
diff --git a/meta-rcar-gen3/recipes-graphics/drm/libdrm/installtests.patch b/meta-rcar-gen3/recipes-graphics/drm/libdrm/installtests.patch
index 30e0a61..ec1fb02 100644
--- a/meta-rcar-gen3/recipes-graphics/drm/libdrm/installtests.patch
+++ b/meta-rcar-gen3/recipes-graphics/drm/libdrm/installtests.patch
@@ -1,15 +1,25 @@
-tests: also install tests app
+From 5c6eb43c2f6e7f2ee7c25c92e42f4e4403fa0527 Mon Sep 17 00:00:00 2001
+From: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Date: Tue, 21 Feb 2017 14:37:52 +0200
+Subject: [PATCH] tests: also install test apps
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Yu Ke <ke.yu@intel.com>
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+---
+ tests/Makefile.am | 1 +
+ 1 file changed, 1 insertion(+)
-Index: libdrm-2.4.66/tests/Makefile.am
-===================================================================
---- libdrm-2.4.66.orig/tests/Makefile.am
-+++ libdrm-2.4.66/tests/Makefile.am
-@@ -73,3 +73,4 @@ TESTS += \
- endif
-
- check_PROGRAMS += $(TESTS)
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index 0355a92..b4882cd 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -45,3 +45,4 @@ TESTS = \
+ check_PROGRAMS = \
+ $(TESTS) \
+ drmdevice
+bin_PROGRAMS = $(check_PROGRAMS)
+--
+2.1.4
+
diff --git a/meta-rcar-gen3/recipes-graphics/drm/libdrm_2.4.68.bb b/meta-rcar-gen3/recipes-graphics/drm/libdrm_2.4.85.bb
index 758f801..4e3e8ef 100644
--- a/meta-rcar-gen3/recipes-graphics/drm/libdrm_2.4.68.bb
+++ b/meta-rcar-gen3/recipes-graphics/drm/libdrm_2.4.85.bb
@@ -8,31 +8,36 @@ SECTION = "x11/base"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://xf86drm.c;beginline=9;endline=32;md5=c8a3b961af7667c530816761e949dc71"
PROVIDES = "drm"
-DEPENDS = "libpthread-stubs udev libpciaccess"
+DEPENDS = "libpthread-stubs libpciaccess"
SRC_URI = "http://dri.freedesktop.org/libdrm/${BP}.tar.bz2 \
file://installtests.patch \
file://fix_O_CLOEXEC_undeclared.patch \
+ file://0001-configure.ac-Allow-explicit-enabling-of-cunit-tests.patch \
"
-SRC_URI[md5sum] = "bcc96848d969cecf28223f668eeff354"
-SRC_URI[sha256sum] = "5b4bd9a5922929bc716411cb74061fbf31b06ba36feb89bc1358a91a8d0ca9df"
+SRC_URI[md5sum] = "7aa540aeea4a1f3d1e9b0828f1772543"
+SRC_URI[sha256sum] = "64e4cd87eaee38ae60b2984ef02b66159b9bdd33030040db2a04339cf15f6173"
-inherit autotools pkgconfig
+inherit autotools pkgconfig manpages
EXTRA_OECONF += "--disable-cairo-tests \
+ --without-cunit \
--enable-omap-experimental-api \
+ --enable-etnaviv-experimental-api \
--enable-install-test-programs \
- --disable-manpages \
--disable-valgrind \
"
+PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native"
ALLOW_EMPTY_${PN}-drivers = "1"
PACKAGES =+ "${PN}-tests ${PN}-drivers ${PN}-radeon ${PN}-nouveau ${PN}-omap \
- ${PN}-intel ${PN}-exynos ${PN}-kms ${PN}-freedreno ${PN}-amdgpu"
+ ${PN}-intel ${PN}-exynos ${PN}-kms ${PN}-freedreno ${PN}-amdgpu \
+ ${PN}-etnaviv"
RRECOMMENDS_${PN}-drivers = "${PN}-radeon ${PN}-nouveau ${PN}-omap ${PN}-intel \
- ${PN}-exynos ${PN}-freedreno ${PN}-amdgpu"
+ ${PN}-exynos ${PN}-freedreno ${PN}-amdgpu \
+ ${PN}-etnaviv"
FILES_${PN}-tests = "${bindir}/*"
FILES_${PN}-radeon = "${libdir}/libdrm_radeon.so.*"
@@ -43,3 +48,4 @@ FILES_${PN}-exynos = "${libdir}/libdrm_exynos.so.*"
FILES_${PN}-kms = "${libdir}/libkms*.so.*"
FILES_${PN}-freedreno = "${libdir}/libdrm_freedreno.so.*"
FILES_${PN}-amdgpu = "${libdir}/libdrm_amdgpu.so.*"
+FILES_${PN}-etnaviv = "${libdir}/libdrm_etnaviv.so.*"