aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2018-02-16 13:35:52 +0100
committerRonan Le Martret <ronan.lemartret@iot.bzh>2018-02-16 13:52:23 +0100
commitcd819d21cd854fee6176dbd9d6ad04c5f976815b (patch)
tree1a02866b2b57ed630e0777752bb24ed94655a22c
parenteae937de9ba5ac9ee5c90cbedae85dca8c0ec261 (diff)
[COMMUNITY] Fix EGL CAST macro
Change-Id: I16d27f915a7acccf8d54cc7278536ded59632a8e Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb2
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module/Fix_EGL_CAST_macro.diff13
2 files changed, 15 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
index bfd406c..aaea680 100644
--- a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
@@ -23,6 +23,8 @@ SRC_URI_append = " \
file://0001-WORKAROUND-using-GLES3-gl3ext.h-from-mesa-to-prevent.patch \
"
+SRC_URI_append = " file://Fix_EGL_CAST_macro.diff "
+
inherit update-rc.d systemd
INITSCRIPT_NAME = "pvrinit"
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module/Fix_EGL_CAST_macro.diff b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module/Fix_EGL_CAST_macro.diff
new file mode 100644
index 0000000..399e86c
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module/Fix_EGL_CAST_macro.diff
@@ -0,0 +1,13 @@
+diff --git a/usr/include/EGL/eglext.h b/usr/include/EGL/eglext.h
+index 4c53540..1606f1d 100644
+--- a/usr/include/EGL/eglext.h
++++ b/usr/include/EGL/eglext.h
+@@ -288,7 +288,7 @@ EGLAPI EGLBoolean EGLAPIENTRY eglStreamConsumerReleaseKHR (EGLDisplay dpy, EGLSt
+ #define EGL_KHR_stream_cross_process_fd 1
+ typedef int EGLNativeFileDescriptorKHR;
+ #ifdef EGL_KHR_stream
+-#define EGL_NO_FILE_DESCRIPTOR_KHR EGL_CAST((EGLNativeFileDescriptorKHR,(-1))
++#define EGL_NO_FILE_DESCRIPTOR_KHR EGL_CAST(EGLNativeFileDescriptorKHR,(-1))
+ typedef EGLNativeFileDescriptorKHR (EGLAPIENTRYP PFNEGLGETSTREAMFILEDESCRIPTORKHRPROC) (EGLDisplay dpy, EGLStreamKHR stream);
+ typedef EGLStreamKHR (EGLAPIENTRYP PFNEGLCREATESTREAMFROMFILEDESCRIPTORKHRPROC) (EGLDisplay dpy, EGLNativeFileDescriptorKHR file_descriptor);
+ #ifdef EGL_EGLEXT_PROTOTYPES