aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-03-29 15:12:49 +0200
committerRonan Le Martret <ronan.lemartret@iot.bzh>2018-05-16 09:34:37 +0200
commit70098fb39bf4458ce3132dc8a91b6aa20ef57f4a (patch)
tree062138a553a7b2eebd321693c6a309782c79408f
parentee9d22cd0127153231c2d60f9441fa9e098e40b5 (diff)
[COMMUNITY] add depends on mesa to gles-user-module
the populate_sysroot of gles-user-module must depends on the populate_sysroot of the virtual/mesa, because header from gles-user-module depends on the header from virtual/mesa. Change-Id: I8368bba6a19ca628a3496a3eebbc18a3c41c322d Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
index 59a188e..a4801ea 100644
--- a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
@@ -31,6 +31,9 @@ SYSTEMD_SERVICE_${PN} = "rc.pvr.service"
do_populate_lic[noexec] = "1"
do_compile[noexec] = "1"
+#The headers of gles-user-module need headers from virtual/mesa.
+do_populate_sysroot[depends] += "virtual/mesa:do_populate_sysroot"
+
do_install() {
# Install configuration files
install -d ${D}/${sysconfdir}/init.d