aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonan Le Martret <ronan.lemartret@iot.bzh>2017-05-03 11:04:40 +0200
committerRonan Le Martret <ronan.lemartret@iot.bzh>2018-05-16 09:34:37 +0200
commitbbc6491577f98389c23193a11bd8fafb8ffa5bbf (patch)
tree2f608510c917dd8ed243dd26030d46214a2c6378
parent35d2cfba531f26befbfdf436990b4b0b14345254 (diff)
[COMMUNITY] Remove hard path from gles-user-module
* replace "/usr/local" with path "${RENESAS_DATADIR}" using: RENESAS_DATADIR = "/usr/local" - meta-rcar-gen3/include/rcar-gen3-path-common.inc * dlcsrv_REL should not be package in ${PN} but ${PN}-dev. dlcsrv_REL can't be install in production. Bug-AGL: SPEC-533 Change-Id: I865ea809c3c59ba136027fc8b99628df20c16275 Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb20
1 files changed, 15 insertions, 5 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
index a4801ea..5866195 100644
--- a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
@@ -1,4 +1,5 @@
require include/gles-control.inc
+require include/rcar-gen3-path-common.inc
DESCRIPTION = "PowerVR GPU user module"
LICENSE = "CLOSED"
@@ -55,8 +56,8 @@ do_install() {
# Install pre-builded binaries
install -d ${D}/${libdir}
install -m 755 ${S}/${libdir}/*.so ${D}/${libdir}/
- install -d ${D}/${exec_prefix}/local/bin
- install -m 755 ${S}/${exec_prefix}/local/bin/dlcsrv_REL ${D}/${exec_prefix}/local/bin/dlcsrv_REL
+ install -d ${D}/${RENESAS_DATADIR}/bin
+ install -m 755 ${S}/usr/local/bin/dlcsrv_REL ${D}/${RENESAS_DATADIR}/bin/dlcsrv_REL
install -d ${D}/lib/firmware
install -m 644 ${S}/lib/firmware/* ${D}/lib/firmware/
@@ -89,14 +90,18 @@ do_install() {
PACKAGES = "\
${PN} \
${PN}-dev \
+ ${PN}-debug \
+"
+
+FILES_${PN}-debug = " \
+ ${RENESAS_DATADIR}/bin/dlcsrv_REL \
"
FILES_${PN} = " \
${sysconfdir}/* \
${libdir}/* \
/lib/firmware/rgx.fw* \
- /usr/local/bin/* \
- ${exec_prefix}/bin/* \
+ ${RENESAS_DATADIR}/bin/pvrinit \
"
FILES_${PN}-dev = " \
@@ -104,7 +109,8 @@ FILES_${PN}-dev = " \
${libdir}/pkgconfig/* \
"
-PROVIDES = "virtual/libgles2 virtual/egl"
+PROVIDES = "virtual/libgles2"
+
RPROVIDES_${PN} += " \
${GLES}-user-module \
libgles2-mesa \
@@ -118,6 +124,10 @@ RDEPENDS_${PN} = " \
${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'libgbm wayland-kms', '', d)} \
"
+RDEPENDS_${PN}-debug = " \
+ libdrm \
+"
+
INSANE_SKIP_${PN} = "ldflags build-deps file-rdeps"
INSANE_SKIP_${PN}-dev = "ldflags build-deps file-rdeps"
INSANE_SKIP_${PN} += "arch"