aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xv@rvc.renesas.com>2018-04-13 11:06:09 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2018-04-21 09:04:25 +0700
commitbf8dcc8e87213c0077af7b13f41f42f9f23370a4 (patch)
tree95f85fa50742a1f1e61d9cbfae5196734bda8121
parent031cf11c6e5fee48d1f92e1af75ab7eb0ddafaa9 (diff)
rcar-gen3: linux-renesas: Upgrade Linux BSP to v3.6.2
This commit upgrades Linux BSP to v3.6.2 for following updates: [Kernel] - "WARNING: possible circular locking dependency detected" occurs with repeating reboot. However, it was false positive, and it was confirmed that there was no problem. - Identify R-Car M3 Ver.1.2 or later. - Remove lossy descompress area from MMNGR node and reduce reserved area for R-Car E3 Ebisu board. [Power Management] - Improve power domains always on implementation. - Fix interrupts are not raised issue on R-Car E3. - Update CAS source. [Display driver] - Add overlay layer size check. - Fix possible crtcs for plane when using VSPDL. [IPMMU driver] - Add workaround for disabling uTLBs. [MSIOF driver] Add MSIOF module clock changing processing for R-Car Series, 3rd Generation. [PCIe driver] - Fix memory leak in of_pci_get_host_bridge_resources. [Thermal driver] - Use DIV_ROUND_CLOSEST correctly as its description. [USB3.0 Host driver] - Cannot Suspend to RAM when enabling USB3.0. - Confirm recognition of USB3.0 memory through HUB for setting /etc/udev/rules.d/99-usb.rules. [Video Capture driver] - Allocate a scratch buffer at stream start. Then use scratch buffer and always run in continuous mode. - Fix PHTW register flow below 250 mbps. - Fix clock control flow so that the warning message “MSTP status timeout” is not displayed and when UDS (scaling) is executed at VIN0, a black screen does not come out. - Fix streaming procedure when resuming. [Audio driver] - Playback or capture doesn’t resume after Suspend to RAM. [USB2.0 Function] - Kernel error occurs with rmmod of g_printer. - The dd command error occurs with g_mass_storage. [USB2.0 Host driver] - When connecting USB mouse, “Bad mode in Error handler” may occur with Suspend to RAM. Signed-off-by: Khang Nguyen <khang.nguyen.xv@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb4
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig3
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb4
3 files changed, 6 insertions, 5 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
index 8585fa9..40fdeb2 100644
--- a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
@@ -3,8 +3,8 @@ require include/iccom-control.inc
RENESAS_BSP_URL = " \
git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.14/rcar-3.6.1"
-SRCREV = "4a7e26bdbc8d210369eab25765c277200cd910a8"
+BRANCH = "v4.14/rcar-3.6.2"
+SRCREV = "a95d91d636e3dcfdb8279a0293da17e90c871186"
SRC_URI = "${RENESAS_BSP_URL};branch=${BRANCH}"
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
index 94c1631..c5ca754 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/defconfig
@@ -5007,7 +5007,8 @@ CONFIG_OF_IOMMU=y
CONFIG_IOMMU_DMA=y
CONFIG_ROCKCHIP_IOMMU=y
# CONFIG_EXYNOS_IOMMU is not set
-# CONFIG_IPMMU_VMSA is not set
+CONFIG_IPMMU_VMSA=y
+CONFIG_IPMMU_VMSA_CTX_NUM=8
CONFIG_ARM_SMMU=y
CONFIG_ARM_SMMU_V3=y
# CONFIG_MTK_IOMMU is not set
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
index 29039b9..5c94645 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
@@ -9,8 +9,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb|ebisu"
RENESAS_BSP_URL = "git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.14/rcar-3.6.1"
-SRCREV = "4a7e26bdbc8d210369eab25765c277200cd910a8"
+BRANCH = "v4.14/rcar-3.6.2"
+SRCREV = "a95d91d636e3dcfdb8279a0293da17e90c871186"
SRC_URI = "${RENESAS_BSP_URL};protocol=git;nocheckout=1;branch=${BRANCH}"