aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-11-01 14:10:35 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-11-24 20:15:57 +0700
commitb0520f15aa887e78c7967a6abd370730658de031 (patch)
tree61d48dd63e015aab6dd136c9dc1107bd9df7a34b
parentd6eff077c4a3afbe39f8ee1b2ad1a19a716ce31c (diff)
rcar-gen3: dpkg: WORKAROUND to fix dependency failed for serial getty
This commit modifies recipe to fix this issue by following Poky commit. Title: dpkg-configure: do not reload daemon configuration Auther: Max Krummenacher <max.oss.09@gmail.com> Commit: b1b94376d15ea18e55f724f1d5256298e1728222 In case a systemd service disables itself while init is still in its boot sequence the reloading of the service files can be problematic. In that case: It seems that systemd looses the state of .device units, and some services depend on such units (namely serial consoles such as serial-getty@ttymxc0.service). As a result no getty is spawned on the affected serial tty. After a power-cycle the second boot (which does not disable services) succeeds. The following sequence shows this problem: | Jan 09 16:36:28 apalis-t30 systemctl[162]: Removed /etc/systemd/system/sysinit.target.wants/run-postinsts.service. | Jan 09 16:36:28 apalis-t30 systemd[1]: Reloading. | ... | And then the failing one: | Feb 22 15:33:15 apalis-t30 systemd[1]: dev-ttyS0.device: Job dev-ttyS0.device/start timed out. | Feb 22 15:33:15 apalis-t30 systemd[1]: Timed out waiting for device dev-ttyS0.device. | Feb 22 15:33:15 apalis-t30 systemd[1]: Dependency failed for Serial Getty on ttyS0. | Feb 22 15:33:15 apalis-t30 systemd[1]: serial-getty@ttyS0.service: Job serial-getty@ttyS0.service/start failed with result 'dependency'. | Feb 22 15:33:15 apalis-t30 systemd[1]: dev-ttyS0.device: Job dev-ttyS0.device/start failed with result 'timeout'. | Feb 22 15:33:15 apalis-t30 systemd[1]: Reached target Login Prompts. (the time has been updated between this two events, but that does not influence the issue) Using --no-reload in the service file avoids the "Reloading." message above and seems to not cause such issues anymore. Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-devtools/dpkg/dpkg_%.bbappend5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-devtools/dpkg/dpkg_%.bbappend b/meta-rcar-gen3/recipes-devtools/dpkg/dpkg_%.bbappend
new file mode 100644
index 0000000..f52cd8e
--- /dev/null
+++ b/meta-rcar-gen3/recipes-devtools/dpkg/dpkg_%.bbappend
@@ -0,0 +1,5 @@
+# Do not reload daemon configuration
+do_install_append () {
+ sed -e 's/\disable/--no-reload \disable/' \
+ -i ${D}${systemd_unitdir}/system/dpkg-configure.service
+}