aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xw@renesas.com>2019-01-28 18:49:51 +0700
committerThuy Tran <thuy.tran.xh@renesas.com>2019-05-23 16:11:56 +0700
commita0b131a7ae8e4773cac431a9e79db2756670cab5 (patch)
treea15f0410042876fb0bafd7330ed3d7e6a8cd8dc3
parent60954be1fb1adee47cb8f04be80bcb3a0a577ec7 (diff)
rcar-gen3: linux-renesas: Upgrade Linux BSP to v3.9.4
This commit upgrades Linux BSP to v3.9.4 for the following changes: - Fix power domain for FCPCS of r8a77965 in the device tree according to H/W UM Rev.1.50 correction in the future. - Rename AVB_AVTP_MATCH and AVB_AVTP_CAPTURE pin function definitions of r8a77990 according to H/W UM Rev.1.50 correction in the future. - Revert the patch of r8a77990 pinctrl about MOD_SEL1 bit31 and bit30 according to H/W UM errata for Rev.1.00. - Fix cpg_sd_clock_round_rate return value. - Rename some pin function and cpg definition according to H/W UM Rev.1.50 errata. - Rename SEL_ADG_B to SEL_ADGB and rename SEL_ADG_C to SEL_ADGC according to H/W UM Rev.1.50. - Fix SCIF5 DMA channels according to H/W UM Rev.1.50. - Fix clock and reset for ivdp1c according to H/W UM Rev.1.50. - Add support for R-Car M3 ES3.0. - Fix MMC cannot probe by modprobe command after S2R issue. Change-Id: I12901a91f2e6ebaf5879456faeb5f9d3baad6f32 Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Duy Dang <duy.dang.yw@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com> (cherry picked from commit 5be728d6bfeb06c3174d5dffd09775d38674dd69)
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers/bugfix-crash-during-Full-HD-playback.patch37
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb9
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas/bugfix-crash-during-Full-HD-playback.patch37
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb9
4 files changed, 4 insertions, 88 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers/bugfix-crash-during-Full-HD-playback.patch b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers/bugfix-crash-during-Full-HD-playback.patch
deleted file mode 100644
index 0d87d44..0000000
--- a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers/bugfix-crash-during-Full-HD-playback.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From b4b3ac9b2bdd5c234251bcf9f843cb972f8c06cf Mon Sep 17 00:00:00 2001
-From: Vitaliy Vasylskyy <vitaliy.vasylskyy@globallogic.com>
-Date: Mon, 17 Dec 2018 15:36:17 +0200
-Subject: [PATCH] bugfix: crash during Full HD playback
-
-This fixes issue with kernel crash during Full HD playback.
-Loop variable was used twice by mistake, so only plane 0 was
-handled properly, and crash happened when plane 1 was in use.
-
-Jira-Id: ADM-2589
-
-Change-Id: I52b69906a10646f5a95220ebced8d3a437ccc89a
-Signed-off-by: Vitaliy Vasylskyy <vitaliy.vasylskyy@globallogic.com>
----
-
-diff --git a/drivers/gpu/drm/rcar-du/rcar_du_vsp.c b/drivers/gpu/drm/rcar-du/rcar_du_vsp.c
-index db32c20..26309fe 100644
---- a/drivers/gpu/drm/rcar-du/rcar_du_vsp.c
-+++ b/drivers/gpu/drm/rcar-du/rcar_du_vsp.c
-@@ -227,7 +227,7 @@
- struct rcar_du_vsp_plane_state *rstate = to_rcar_vsp_plane_state(state);
- struct rcar_du_vsp *vsp = to_rcar_vsp_plane(plane)->vsp;
- struct rcar_du_device *rcdu = vsp->dev;
-- unsigned int i;
-+ unsigned int i, j;
- int ret;
-
- /*
-@@ -260,7 +260,7 @@
-
- src = gem->sgt->sgl;
- dst = sgt->sgl;
-- for (i = 0; i < gem->sgt->orig_nents; ++i) {
-+ for (j = 0; j < gem->sgt->orig_nents; ++j) {
- sg_set_page(dst, sg_page(src), src->length,
- src->offset);
- src = sg_next(src);
diff --git a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
index 6febdd3..5b3707c 100644
--- a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.14.bb
@@ -4,8 +4,8 @@ require include/adsp-control.inc
RENESAS_BSP_URL = " \
git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.14.75-ltsi/rcar-3.9.2"
-SRCREV = "a5266d298124874c2c06b8b13d073f6ecc2ee355"
+BRANCH = "v4.14.75-ltsi/rcar-3.9.4"
+SRCREV = "1f12f0466c7782ef7f44481ecf08db5e77448c7f"
SRC_URI = "${RENESAS_BSP_URL};branch=${BRANCH}"
@@ -36,8 +36,3 @@ S = "${WORKDIR}/git"
SRC_URI_append = " \
file://0001-arm64-bpf-correct-broken-uapi-for-BPF_PROG_TYPE_PERF.patch \
"
-
-# W/A to fix kernel crash
-SRC_URI_append = " \
- file://bugfix-crash-during-Full-HD-playback.patch \
-"
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/bugfix-crash-during-Full-HD-playback.patch b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/bugfix-crash-during-Full-HD-playback.patch
deleted file mode 100644
index 0d87d44..0000000
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas/bugfix-crash-during-Full-HD-playback.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From b4b3ac9b2bdd5c234251bcf9f843cb972f8c06cf Mon Sep 17 00:00:00 2001
-From: Vitaliy Vasylskyy <vitaliy.vasylskyy@globallogic.com>
-Date: Mon, 17 Dec 2018 15:36:17 +0200
-Subject: [PATCH] bugfix: crash during Full HD playback
-
-This fixes issue with kernel crash during Full HD playback.
-Loop variable was used twice by mistake, so only plane 0 was
-handled properly, and crash happened when plane 1 was in use.
-
-Jira-Id: ADM-2589
-
-Change-Id: I52b69906a10646f5a95220ebced8d3a437ccc89a
-Signed-off-by: Vitaliy Vasylskyy <vitaliy.vasylskyy@globallogic.com>
----
-
-diff --git a/drivers/gpu/drm/rcar-du/rcar_du_vsp.c b/drivers/gpu/drm/rcar-du/rcar_du_vsp.c
-index db32c20..26309fe 100644
---- a/drivers/gpu/drm/rcar-du/rcar_du_vsp.c
-+++ b/drivers/gpu/drm/rcar-du/rcar_du_vsp.c
-@@ -227,7 +227,7 @@
- struct rcar_du_vsp_plane_state *rstate = to_rcar_vsp_plane_state(state);
- struct rcar_du_vsp *vsp = to_rcar_vsp_plane(plane)->vsp;
- struct rcar_du_device *rcdu = vsp->dev;
-- unsigned int i;
-+ unsigned int i, j;
- int ret;
-
- /*
-@@ -260,7 +260,7 @@
-
- src = gem->sgt->sgl;
- dst = sgt->sgl;
-- for (i = 0; i < gem->sgt->orig_nents; ++i) {
-+ for (j = 0; j < gem->sgt->orig_nents; ++j) {
- sg_set_page(dst, sg_page(src), src->length,
- src->offset);
- src = sg_next(src);
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
index a913350..393af01 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.14.bb
@@ -11,8 +11,8 @@ COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb|m3nulcb|ebisu"
RENESAS_BSP_URL = " \
git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.14.75-ltsi/rcar-3.9.2"
-SRCREV = "a5266d298124874c2c06b8b13d073f6ecc2ee355"
+BRANCH = "v4.14.75-ltsi/rcar-3.9.4"
+SRCREV = "1f12f0466c7782ef7f44481ecf08db5e77448c7f"
SRC_URI = "${RENESAS_BSP_URL};protocol=git;nocheckout=1;branch=${BRANCH}"
@@ -73,11 +73,6 @@ SRC_URI_append = " \
file://0001-arm64-bpf-correct-broken-uapi-for-BPF_PROG_TYPE_PERF.patch \
"
-# W/A to fix kernel crash
-SRC_URI_append = " \
- file://bugfix-crash-during-Full-HD-playback.patch \
-"
-
do_download_firmware () {
install -m 755 ${WORKDIR}/r8a779x_usb3_v*.dlmem ${STAGING_KERNEL_DIR}/firmware
}