aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2018-01-19 21:03:43 +0900
committerHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2018-01-19 21:03:43 +0900
commita48ffafe4d786415464a781a35155d9afa8fe68a (patch)
treef863e2cfd163ade5e6f9ce9aeaf701a387197dd1
parent2e1a7e39e012ea4436c819f46cfcac05fb161184 (diff)
Revert "V3M: update ROM API table for ws2.0"
This reverts commit cab418c222a69d570913df84ff906d5c4493c453.
-rw-r--r--meta-rcar-gen3-adas/recipes-bsp/arm-trusted-firmware/files/0003-plat-renesas-rcar-V3M-support.patch29
1 files changed, 15 insertions, 14 deletions
diff --git a/meta-rcar-gen3-adas/recipes-bsp/arm-trusted-firmware/files/0003-plat-renesas-rcar-V3M-support.patch b/meta-rcar-gen3-adas/recipes-bsp/arm-trusted-firmware/files/0003-plat-renesas-rcar-V3M-support.patch
index 822895a..ea8a57c 100644
--- a/meta-rcar-gen3-adas/recipes-bsp/arm-trusted-firmware/files/0003-plat-renesas-rcar-V3M-support.patch
+++ b/meta-rcar-gen3-adas/recipes-bsp/arm-trusted-firmware/files/0003-plat-renesas-rcar-V3M-support.patch
@@ -17,7 +17,7 @@ Signed-off-by: Vladimir Barinov <vladimir.barinov@cogentembedded.com>
plat/renesas/rcar/ddr/boot_init_dram_regdef.h | 1 +
plat/renesas/rcar/ddr/ddr.mk | 3 +
plat/renesas/rcar/drivers/board/board.c | 2 +-
- plat/renesas/rcar/drivers/rom/rom_api.c | 18 +-
+ plat/renesas/rcar/drivers/rom/rom_api.c | 19 +-
plat/renesas/rcar/drivers/scif/scif.S | 29 +-
plat/renesas/rcar/include/bl2_dma_register.h | 4 +
plat/renesas/rcar/pfc/V3M/pfc_init_v3m.c | 1076 ++++++++++++++++++++
@@ -30,7 +30,7 @@ Signed-off-by: Vladimir Barinov <vladimir.barinov@cogentembedded.com>
plat/renesas/rcar/qos/qos.mk | 7 +
plat/renesas/rcar/qos/qos_init.c | 25 +
plat/renesas/rcar/rcar_def.h | 1 +
- 23 files changed, 2490 insertions(+), 13 deletions(-)
+ 23 files changed, 2492 insertions(+), 12 deletions(-)
mode change 100644 => 100755 plat/renesas/rcar/bl2_rcar_setup.c
create mode 100644 plat/renesas/rcar/ddr/V3M/boot_init_dram_regdef_v3m.h
create mode 100644 plat/renesas/rcar/ddr/V3M/boot_init_dram_v3m.h
@@ -1027,42 +1027,43 @@ index d38cf36..87c5faf 100644
#define SLAVE_ADDR_EEPROM (0x50U)
diff --git a/plat/renesas/rcar/drivers/rom/rom_api.c b/plat/renesas/rcar/drivers/rom/rom_api.c
-index b54ed20..186660d 100644
+index b54ed20..dad69e6 100644
--- a/plat/renesas/rcar/drivers/rom/rom_api.c
+++ b/plat/renesas/rcar/drivers/rom/rom_api.c
-@@ -52,8 +52,9 @@ static uint32_t get_table_index(void);
- #define OLD_API_TABLE1 (0U) /* H3 WS1.0/WS1.1 */
+@@ -53,7 +53,9 @@ static uint32_t get_table_index(void);
#define OLD_API_TABLE2 (1U) /* H3 WS2.0 */
#define OLD_API_TABLE3 (2U) /* M3 WS1.0/1.05 */
--#define NEW_API_TABLE (3U) /* M3 WS1.06 or later, M3N, E3 */
+ #define NEW_API_TABLE (3U) /* M3 WS1.06 or later, M3N, E3 */
-#define API_TABLE_MAX (4U) /* table max */
-+#define NEW_API_TABLE (3U) /* M3 WS1.06 or later, M3N, E3, V3M WS2.0 */
+#define NEW_API_TABLE2 (4U) /* V3M WS1.0 */
-+#define API_TABLE_MAX (5U) /* table max */
++#define NEW_API_TABLE3 (5U) /* V3M WS2.0 */
++#define API_TABLE_MAX (6U) /* table max */
-@@ -66,7 +67,8 @@ uint32_t ROM_SecureBootAPI( uint32_t *pKeyCert,
+@@ -66,7 +68,9 @@ uint32_t ROM_SecureBootAPI( uint32_t *pKeyCert,
0xEB10DD64U, /* H3 WS1.0/WS1.1 */
0xEB116ED4U, /* H3 WS2.0 */
0xEB1102FCU, /* M3 WS1.0/1.05 */
- 0xEB100180U /* M3 WS1.06 or later, M3N, E3 */
-+ 0xEB100180U, /* M3 WS1.06 or later, M3N, E3, V3M WS2.0 */
++ 0xEB100180U, /* M3 WS1.06 or later, M3N, E3 */
+ 0xEB110128U, /* V3M WS1.0 */
++ 0xEB110128U, /* V3M WS2.0 ?? */
};
ROM_SECURE_BOOT_API func;
-@@ -86,7 +88,8 @@ uint32_t ROM_GetLcs(uint32_t *pLcs)
+@@ -86,7 +90,9 @@ uint32_t ROM_GetLcs(uint32_t *pLcs)
0xEB10DFE0U, /* H3 WS1.0/WS1.1 */
0xEB117150U, /* H3 WS2.0 */
0xEB110578U, /* M3 WS1.0/1.05 */
- 0xEB10018CU /* M3 WS1.06 or later, M3N, E3 */
-+ 0xEB10018CU, /* M3 WS1.06 or later, M3N, E3, V3M WS2.0 */
++ 0xEB10018CU, /* M3 WS1.06 or later, M3N, E3 */
+ 0xEB1103A4U, /* V3M WS1.0 */
++ 0xEB1103A4U, /* V3M WS2.0 ?? */
};
ROM_GETLCS_API func;
-@@ -135,6 +138,13 @@ static uint32_t get_table_index(void)
+@@ -135,6 +141,13 @@ static uint32_t get_table_index(void)
index = NEW_API_TABLE; /* M3 WS1.1 or later */
}
break;
@@ -1070,7 +1071,7 @@ index b54ed20..186660d 100644
+ if (cut_ver == RCAR_CUT_ES10) {
+ index = NEW_API_TABLE2; /* V3M WS1.0 */
+ } else {
-+ index = NEW_API_TABLE; /* V3M WS2.0 or later */
++ index = NEW_API_TABLE3; /* V3M WS2.0 or later */
+ }
+ break;
default: