aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Dolnikov <andrey.dolnikov@cogentembedded.com>2018-04-16 12:07:32 +0300
committerAndrey Dolnikov <andrey.dolnikov@cogentembedded.com>2018-04-16 16:09:15 +0300
commit1e40e21e5dc5da75931ed835c624147d25af4b55 (patch)
tree86bd842146adf32ca7cbe6b98ad9575b174b7406
parent4ae3ea734b05c22620e7108885f4d28305ceaae7 (diff)
Add ISP UIO driver.
-rw-r--r--meta-rcar-gen3-adas/conf/layer.conf9
-rw-r--r--meta-rcar-gen3-adas/recipes-core/udev/udev-rules-cvlib.bb2
-rw-r--r--meta-rcar-gen3-adas/recipes-core/udev/udev-rules-cvlib/54-isp.rules1
-rw-r--r--meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/GPL-COPYING339
-rw-r--r--meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/MIT-COPYING41
-rw-r--r--meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/Makefile14
-rw-r--r--meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/uio_isp.c450
-rw-r--r--meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/kernel-module-uio-isp_0.1.bb27
8 files changed, 883 insertions, 0 deletions
diff --git a/meta-rcar-gen3-adas/conf/layer.conf b/meta-rcar-gen3-adas/conf/layer.conf
index 8524ff6..70bd486 100644
--- a/meta-rcar-gen3-adas/conf/layer.conf
+++ b/meta-rcar-gen3-adas/conf/layer.conf
@@ -96,6 +96,15 @@ IMAGE_INSTALL_append_r8a7798 += " \
udev-rules-cvlib \
"
+# ISP
+IMAGE_INSTALL_append_r8a7797 += " \
+ kernel-module-uio-isp \
+"
+
+IMAGE_INSTALL_append_r8a7798 += " \
+ kernel-module-uio-isp \
+"
+
DISTRO_FEATURES_remove="x11"
DISTRO_FEATURES_append = " surroundview "
DISTRO_FEATURES_append = " opencv-sdk "
diff --git a/meta-rcar-gen3-adas/recipes-core/udev/udev-rules-cvlib.bb b/meta-rcar-gen3-adas/recipes-core/udev/udev-rules-cvlib.bb
index 3cff673..023f6fd 100644
--- a/meta-rcar-gen3-adas/recipes-core/udev/udev-rules-cvlib.bb
+++ b/meta-rcar-gen3-adas/recipes-core/udev/udev-rules-cvlib.bb
@@ -5,6 +5,7 @@ SRC_URI = " \
file://51-imp.rules \
file://52-cmem.rules \
file://53-vip.rules \
+ file://54-isp.rules \
"
do_install () {
@@ -12,4 +13,5 @@ do_install () {
install -m 0644 ${WORKDIR}/51-imp.rules ${D}${sysconfdir}/udev/rules.d/
install -m 0644 ${WORKDIR}/52-cmem.rules ${D}${sysconfdir}/udev/rules.d/
install -m 0644 ${WORKDIR}/53-vip.rules ${D}${sysconfdir}/udev/rules.d/
+ install -m 0644 ${WORKDIR}/54-isp.rules ${D}${sysconfdir}/udev/rules.d/
}
diff --git a/meta-rcar-gen3-adas/recipes-core/udev/udev-rules-cvlib/54-isp.rules b/meta-rcar-gen3-adas/recipes-core/udev/udev-rules-cvlib/54-isp.rules
new file mode 100644
index 0000000..e4e1b28
--- /dev/null
+++ b/meta-rcar-gen3-adas/recipes-core/udev/udev-rules-cvlib/54-isp.rules
@@ -0,0 +1 @@
+SUBSYSTEM=="uio", ATTR{name}=="*isp*", SYMLINK+="$attr{name}", MODE="0666"
diff --git a/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/GPL-COPYING b/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/GPL-COPYING
new file mode 100644
index 0000000..d159169
--- /dev/null
+++ b/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/GPL-COPYING
@@ -0,0 +1,339 @@
+ GNU GENERAL PUBLIC LICENSE
+ Version 2, June 1991
+
+ Copyright (C) 1989, 1991 Free Software Foundation, Inc.,
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ Everyone is permitted to copy and distribute verbatim copies
+ of this license document, but changing it is not allowed.
+
+ Preamble
+
+ The licenses for most software are designed to take away your
+freedom to share and change it. By contrast, the GNU General Public
+License is intended to guarantee your freedom to share and change free
+software--to make sure the software is free for all its users. This
+General Public License applies to most of the Free Software
+Foundation's software and to any other program whose authors commit to
+using it. (Some other Free Software Foundation software is covered by
+the GNU Lesser General Public License instead.) You can apply it to
+your programs, too.
+
+ When we speak of free software, we are referring to freedom, not
+price. Our General Public Licenses are designed to make sure that you
+have the freedom to distribute copies of free software (and charge for
+this service if you wish), that you receive source code or can get it
+if you want it, that you can change the software or use pieces of it
+in new free programs; and that you know you can do these things.
+
+ To protect your rights, we need to make restrictions that forbid
+anyone to deny you these rights or to ask you to surrender the rights.
+These restrictions translate to certain responsibilities for you if you
+distribute copies of the software, or if you modify it.
+
+ For example, if you distribute copies of such a program, whether
+gratis or for a fee, you must give the recipients all the rights that
+you have. You must make sure that they, too, receive or can get the
+source code. And you must show them these terms so they know their
+rights.
+
+ We protect your rights with two steps: (1) copyright the software, and
+(2) offer you this license which gives you legal permission to copy,
+distribute and/or modify the software.
+
+ Also, for each author's protection and ours, we want to make certain
+that everyone understands that there is no warranty for this free
+software. If the software is modified by someone else and passed on, we
+want its recipients to know that what they have is not the original, so
+that any problems introduced by others will not reflect on the original
+authors' reputations.
+
+ Finally, any free program is threatened constantly by software
+patents. We wish to avoid the danger that redistributors of a free
+program will individually obtain patent licenses, in effect making the
+program proprietary. To prevent this, we have made it clear that any
+patent must be licensed for everyone's free use or not licensed at all.
+
+ The precise terms and conditions for copying, distribution and
+modification follow.
+
+ GNU GENERAL PUBLIC LICENSE
+ TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
+
+ 0. This License applies to any program or other work which contains
+a notice placed by the copyright holder saying it may be distributed
+under the terms of this General Public License. The "Program", below,
+refers to any such program or work, and a "work based on the Program"
+means either the Program or any derivative work under copyright law:
+that is to say, a work containing the Program or a portion of it,
+either verbatim or with modifications and/or translated into another
+language. (Hereinafter, translation is included without limitation in
+the term "modification".) Each licensee is addressed as "you".
+
+Activities other than copying, distribution and modification are not
+covered by this License; they are outside its scope. The act of
+running the Program is not restricted, and the output from the Program
+is covered only if its contents constitute a work based on the
+Program (independent of having been made by running the Program).
+Whether that is true depends on what the Program does.
+
+ 1. You may copy and distribute verbatim copies of the Program's
+source code as you receive it, in any medium, provided that you
+conspicuously and appropriately publish on each copy an appropriate
+copyright notice and disclaimer of warranty; keep intact all the
+notices that refer to this License and to the absence of any warranty;
+and give any other recipients of the Program a copy of this License
+along with the Program.
+
+You may charge a fee for the physical act of transferring a copy, and
+you may at your option offer warranty protection in exchange for a fee.
+
+ 2. You may modify your copy or copies of the Program or any portion
+of it, thus forming a work based on the Program, and copy and
+distribute such modifications or work under the terms of Section 1
+above, provided that you also meet all of these conditions:
+
+ a) You must cause the modified files to carry prominent notices
+ stating that you changed the files and the date of any change.
+
+ b) You must cause any work that you distribute or publish, that in
+ whole or in part contains or is derived from the Program or any
+ part thereof, to be licensed as a whole at no charge to all third
+ parties under the terms of this License.
+
+ c) If the modified program normally reads commands interactively
+ when run, you must cause it, when started running for such
+ interactive use in the most ordinary way, to print or display an
+ announcement including an appropriate copyright notice and a
+ notice that there is no warranty (or else, saying that you provide
+ a warranty) and that users may redistribute the program under
+ these conditions, and telling the user how to view a copy of this
+ License. (Exception: if the Program itself is interactive but
+ does not normally print such an announcement, your work based on
+ the Program is not required to print an announcement.)
+
+These requirements apply to the modified work as a whole. If
+identifiable sections of that work are not derived from the Program,
+and can be reasonably considered independent and separate works in
+themselves, then this License, and its terms, do not apply to those
+sections when you distribute them as separate works. But when you
+distribute the same sections as part of a whole which is a work based
+on the Program, the distribution of the whole must be on the terms of
+this License, whose permissions for other licensees extend to the
+entire whole, and thus to each and every part regardless of who wrote it.
+
+Thus, it is not the intent of this section to claim rights or contest
+your rights to work written entirely by you; rather, the intent is to
+exercise the right to control the distribution of derivative or
+collective works based on the Program.
+
+In addition, mere aggregation of another work not based on the Program
+with the Program (or with a work based on the Program) on a volume of
+a storage or distribution medium does not bring the other work under
+the scope of this License.
+
+ 3. You may copy and distribute the Program (or a work based on it,
+under Section 2) in object code or executable form under the terms of
+Sections 1 and 2 above provided that you also do one of the following:
+
+ a) Accompany it with the complete corresponding machine-readable
+ source code, which must be distributed under the terms of Sections
+ 1 and 2 above on a medium customarily used for software interchange; or,
+
+ b) Accompany it with a written offer, valid for at least three
+ years, to give any third party, for a charge no more than your
+ cost of physically performing source distribution, a complete
+ machine-readable copy of the corresponding source code, to be
+ distributed under the terms of Sections 1 and 2 above on a medium
+ customarily used for software interchange; or,
+
+ c) Accompany it with the information you received as to the offer
+ to distribute corresponding source code. (This alternative is
+ allowed only for noncommercial distribution and only if you
+ received the program in object code or executable form with such
+ an offer, in accord with Subsection b above.)
+
+The source code for a work means the preferred form of the work for
+making modifications to it. For an executable work, complete source
+code means all the source code for all modules it contains, plus any
+associated interface definition files, plus the scripts used to
+control compilation and installation of the executable. However, as a
+special exception, the source code distributed need not include
+anything that is normally distributed (in either source or binary
+form) with the major components (compiler, kernel, and so on) of the
+operating system on which the executable runs, unless that component
+itself accompanies the executable.
+
+If distribution of executable or object code is made by offering
+access to copy from a designated place, then offering equivalent
+access to copy the source code from the same place counts as
+distribution of the source code, even though third parties are not
+compelled to copy the source along with the object code.
+
+ 4. You may not copy, modify, sublicense, or distribute the Program
+except as expressly provided under this License. Any attempt
+otherwise to copy, modify, sublicense or distribute the Program is
+void, and will automatically terminate your rights under this License.
+However, parties who have received copies, or rights, from you under
+this License will not have their licenses terminated so long as such
+parties remain in full compliance.
+
+ 5. You are not required to accept this License, since you have not
+signed it. However, nothing else grants you permission to modify or
+distribute the Program or its derivative works. These actions are
+prohibited by law if you do not accept this License. Therefore, by
+modifying or distributing the Program (or any work based on the
+Program), you indicate your acceptance of this License to do so, and
+all its terms and conditions for copying, distributing or modifying
+the Program or works based on it.
+
+ 6. Each time you redistribute the Program (or any work based on the
+Program), the recipient automatically receives a license from the
+original licensor to copy, distribute or modify the Program subject to
+these terms and conditions. You may not impose any further
+restrictions on the recipients' exercise of the rights granted herein.
+You are not responsible for enforcing compliance by third parties to
+this License.
+
+ 7. If, as a consequence of a court judgment or allegation of patent
+infringement or for any other reason (not limited to patent issues),
+conditions are imposed on you (whether by court order, agreement or
+otherwise) that contradict the conditions of this License, they do not
+excuse you from the conditions of this License. If you cannot
+distribute so as to satisfy simultaneously your obligations under this
+License and any other pertinent obligations, then as a consequence you
+may not distribute the Program at all. For example, if a patent
+license would not permit royalty-free redistribution of the Program by
+all those who receive copies directly or indirectly through you, then
+the only way you could satisfy both it and this License would be to
+refrain entirely from distribution of the Program.
+
+If any portion of this section is held invalid or unenforceable under
+any particular circumstance, the balance of the section is intended to
+apply and the section as a whole is intended to apply in other
+circumstances.
+
+It is not the purpose of this section to induce you to infringe any
+patents or other property right claims or to contest validity of any
+such claims; this section has the sole purpose of protecting the
+integrity of the free software distribution system, which is
+implemented by public license practices. Many people have made
+generous contributions to the wide range of software distributed
+through that system in reliance on consistent application of that
+system; it is up to the author/donor to decide if he or she is willing
+to distribute software through any other system and a licensee cannot
+impose that choice.
+
+This section is intended to make thoroughly clear what is believed to
+be a consequence of the rest of this License.
+
+ 8. If the distribution and/or use of the Program is restricted in
+certain countries either by patents or by copyrighted interfaces, the
+original copyright holder who places the Program under this License
+may add an explicit geographical distribution limitation excluding
+those countries, so that distribution is permitted only in or among
+countries not thus excluded. In such case, this License incorporates
+the limitation as if written in the body of this License.
+
+ 9. The Free Software Foundation may publish revised and/or new versions
+of the General Public License from time to time. Such new versions will
+be similar in spirit to the present version, but may differ in detail to
+address new problems or concerns.
+
+Each version is given a distinguishing version number. If the Program
+specifies a version number of this License which applies to it and "any
+later version", you have the option of following the terms and conditions
+either of that version or of any later version published by the Free
+Software Foundation. If the Program does not specify a version number of
+this License, you may choose any version ever published by the Free Software
+Foundation.
+
+ 10. If you wish to incorporate parts of the Program into other free
+programs whose distribution conditions are different, write to the author
+to ask for permission. For software which is copyrighted by the Free
+Software Foundation, write to the Free Software Foundation; we sometimes
+make exceptions for this. Our decision will be guided by the two goals
+of preserving the free status of all derivatives of our free software and
+of promoting the sharing and reuse of software generally.
+
+ NO WARRANTY
+
+ 11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY
+FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN
+OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES
+PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED
+OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS
+TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE
+PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING,
+REPAIR OR CORRECTION.
+
+ 12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING
+WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR
+REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES,
+INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING
+OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED
+TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY
+YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER
+PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGES.
+
+ END OF TERMS AND CONDITIONS
+
+ How to Apply These Terms to Your New Programs
+
+ If you develop a new program, and you want it to be of the greatest
+possible use to the public, the best way to achieve this is to make it
+free software which everyone can redistribute and change under these terms.
+
+ To do so, attach the following notices to the program. It is safest
+to attach them to the start of each source file to most effectively
+convey the exclusion of warranty; and each file should have at least
+the "copyright" line and a pointer to where the full notice is found.
+
+ <one line to give the program's name and a brief idea of what it does.>
+ Copyright (C) <year> <name of author>
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License along
+ with this program; if not, write to the Free Software Foundation, Inc.,
+ 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+Also add information on how to contact you by electronic and paper mail.
+
+If the program is interactive, make it output a short notice like this
+when it starts in an interactive mode:
+
+ Gnomovision version 69, Copyright (C) year name of author
+ Gnomovision comes with ABSOLUTELY NO WARRANTY; for details type `show w'.
+ This is free software, and you are welcome to redistribute it
+ under certain conditions; type `show c' for details.
+
+The hypothetical commands `show w' and `show c' should show the appropriate
+parts of the General Public License. Of course, the commands you use may
+be called something other than `show w' and `show c'; they could even be
+mouse-clicks or menu items--whatever suits your program.
+
+You should also get your employer (if you work as a programmer) or your
+school, if any, to sign a "copyright disclaimer" for the program, if
+necessary. Here is a sample; alter the names:
+
+ Yoyodyne, Inc., hereby disclaims all copyright interest in the program
+ `Gnomovision' (which makes passes at compilers) written by James Hacker.
+
+ <signature of Ty Coon>, 1 April 1989
+ Ty Coon, President of Vice
+
+This General Public License does not permit incorporating your program into
+proprietary programs. If your program is a subroutine library, you may
+consider it more useful to permit linking proprietary applications with the
+library. If this is what you want to do, use the GNU Lesser General
+Public License instead of this License.
diff --git a/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/MIT-COPYING b/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/MIT-COPYING
new file mode 100644
index 0000000..28e2a15
--- /dev/null
+++ b/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/MIT-COPYING
@@ -0,0 +1,41 @@
+
+This software is Copyright (C) 2013 Renesas Electronics Corporation
+
+You may use, distribute and copy this software under the terms of the MIT
+license displayed below.
+
+-----------------------------------------------------------------------------
+
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+
+ The above copyright notice and this permission notice shall be included in
+ all copies or substantial portions of the Software.
+
+ Alternatively, the contents of this file may be used under the terms of
+ the GNU General Public License Version 2 ("GPL") in which case the provisions
+ of GPL are applicable instead of those above.
+
+ If you wish to allow use of your version of this file only under the terms of
+ GPL, and not to allow others to use your version of this file under the terms
+ of the MIT license, indicate your decision by deleting the provisions above
+ and replace them with the notice and other provisions required by GPL as set
+ out in the file called "GPL-COPYING" included in this distribution. If you do
+ not delete the provisions above, a recipient may use your version of this file
+ under the terms of either the MIT license or GPL.
+
+-----------------------------------------------------------------------------
+
+ EXCEPT AS OTHERWISE STATED IN A NEGOTIATED AGREEMENT: (A) THE SOFTWARE IS
+ PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING
+ BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR
+ PURPOSE AND NONINFRINGEMENT; AND (B) IN NO EVENT SHALL THE AUTHORS OR
+ COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+ IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+ CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-----------------------------------------------------------------------------
diff --git a/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/Makefile b/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/Makefile
new file mode 100644
index 0000000..33c2ced
--- /dev/null
+++ b/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/Makefile
@@ -0,0 +1,14 @@
+obj-m := uio_isp.o
+
+SRC := $(shell pwd)
+
+all:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC)
+
+modules_install:
+ $(MAKE) -C $(KERNEL_SRC) M=$(SRC) modules_install
+
+clean:
+ rm -f *.o *~ core .depend .*.cmd *.ko *.mod.c
+ rm -f Module.markers Module.symvers modules.order
+ rm -rf .tmp_versions Modules.symvers
diff --git a/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/uio_isp.c b/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/uio_isp.c
new file mode 100644
index 0000000..5898b01
--- /dev/null
+++ b/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/files/uio_isp.c
@@ -0,0 +1,450 @@
+/**
+ * This driver module supports both the ISP itself and the ISP Wrapper
+ * by providing the user with two separate UIO devices in /dev, one for the
+ * ISP and one for the ISP Wrapper. The struct uio_isp_platform_data contains
+ * the uio_info for the ISP as well as the ISP Wrapper.
+ * The ISP has to be defined in the Device Tree using the following structure
+ isp0: isp@fec00000 {
+ compatible = "renesas,isp-r8a7797";
+ reg = <0 0xfec00000 0 0x20000>, <0 0xfed00000 0 0x10000>;
+ interrupts = <GIC_SPI 26 IRQ_TYPE_LEVEL_HIGH>, <GIC_SPI 25 IRQ_TYPE_LEVEL_HIGH>;
+ clocks = <&cpg CPG_MOD 817>;
+ power-domains = <&sysc R8A7797_PD_ALWAYS_ON>;
+ };
+ * The first reg entry is the base and size of the ISP memory area.
+ * The second reg entry is the base and size of the ISP Wrapper memory area.
+ * The first interrupt entry is for the ISP.
+ * The second interrupt entry is for the ISP Wrapper
+ */
+
+#include <linux/module.h>
+#include <linux/kernel.h>
+#include <linux/init.h>
+#include <linux/clk.h>
+#include <linux/dma-mapping.h>
+#include <linux/platform_device.h>
+#include <linux/uio_driver.h>
+#include <linux/io.h>
+#include <linux/irq.h>
+#include <linux/irqdomain.h>
+#include <linux/pm_runtime.h>
+
+#include <linux/of.h>
+#include <linux/of_irq.h>
+
+
+/* ISP internals */
+#define ISP_INTERNAL_REG_SIZE 0X20000
+#define ISP_INT_FRAME_START_MASK 0x84
+#define ISP_INT_FRAME_START_STATUS 0x88
+#define ISP_INT_FRAME_START_CLEAR 0x8c
+#define ISP_INT_FRAME_END_MASK 0x98
+#define ISP_INT_FRAME_END_STATUS 0x9c
+#define ISP_INT_FRAME_END_CLEAR 0xa0
+#define ISP_INT_STATS_MASK 0xb0
+#define ISP_INT_STATS_STATUS 0xb4
+#define ISP_INT_STATS_CLEAR 0xb8
+
+/* ISP Wrapper internals */
+#define ISPVCR 0x00
+#define ISPINT_STATUS 0x40
+#define ISPINT_ENABLE 0x60
+#define ISPERR0_ENABLE 0x64
+
+/* ISP uio driver name */
+#define DRIVER_NAME "uio_isp"
+#define DRIVER_VERSION "0.1"
+
+/* Platform data for ISP and ISP Wrapper */
+struct uio_isp_platform_data
+{
+ struct platform_device *pdev;
+ struct uio_info *uio_info[2]; /* [0]: ISP [1]: ISP Wrapper */
+ struct clk *isp_clock;
+ spinlock_t isp_lock;
+ spinlock_t wrapper_lock;
+ unsigned long isp_flags;
+ unsigned long wrapper_flags;
+ void __iomem *base_addr;
+ void __iomem *wrapper_addr;
+};
+
+/* ISP Wrapper function prototypes */
+static int isp_wrapper_probe(struct platform_device *pdev, struct uio_isp_platform_data * const priv);
+static int isp_wrapper_open(struct uio_info *uio_info, struct inode *inode);
+static int isp_wrapper_close(struct uio_info *uio_info, struct inode *inode);
+static irqreturn_t isp_wrapper_irq_handler(int irq, struct uio_info *uio_info);
+
+/* ISP function prototypes */
+static int isp_probe(struct platform_device *pdev, struct uio_isp_platform_data * const priv);
+static int isp_open(struct uio_info *uio_info, struct inode *inode);
+static int isp_close(struct uio_info *uio_info, struct inode *inode);
+static irqreturn_t isp_irq_handler(int irq, struct uio_info *uio_info);
+
+/* Common functions for ISP and ISP Wrapper */
+static int irq_control(struct uio_info *uio_info, s32 irq_on);
+
+static inline u32 read_reg(void * const base, const u32 offset)
+{
+ return ioread32((u8 *)base + offset);
+}
+
+static inline void write_reg(void * const base, const u32 offset, const u32 val)
+{
+ iowrite32(val, (u8 *)base + offset);
+}
+
+/* Function definitions */
+static int isp_wrapper_probe(struct platform_device *pdev, struct uio_isp_platform_data * const priv)
+{
+ struct uio_info *uio_info;
+ struct uio_mem *uio_mem;
+ struct resource *res;
+ char *wrapper_name;
+ int err;
+ struct device *dev = &pdev->dev;
+
+ /* Construct the uio_info structure */
+ uio_info = devm_kzalloc(dev, sizeof(*uio_info), GFP_KERNEL);
+ wrapper_name = devm_kmalloc(dev, strlen(pdev->name) + strlen("_wrapper") + 1, GFP_KERNEL);
+ if (!uio_info || !wrapper_name)
+ return -ENOMEM;
+ sprintf(wrapper_name, "%s_wrapper", pdev->name);
+ uio_info->version = DRIVER_VERSION;
+ uio_info->open = isp_wrapper_open;
+ uio_info->release = isp_wrapper_close;
+ uio_info->name = wrapper_name;
+
+ /* Set up memory resource */
+ uio_mem = &uio_info->mem[0];
+ res = platform_get_resource(pdev, IORESOURCE_MEM, 1);
+ if (!res) {
+ dev_err(dev, "failed to get ISP Wrapper memory\n");
+ return -EINVAL;
+ }
+ uio_mem->memtype = UIO_MEM_PHYS;
+ uio_mem->addr = res->start;
+ uio_mem->size = resource_size(res);
+ uio_mem->name = res->name;
+ if (!devm_request_mem_region(dev, res->start, resource_size(res), uio_info->name)) {
+ dev_err(dev, "failed to reserve ISP Wrapper memory\n");
+ return -ENOMEM;
+ }
+ priv->wrapper_addr = devm_ioremap_nocache(dev, res->start, resource_size(res));
+ if (!priv->wrapper_addr) {
+ dev_err(dev, "failed to map ISP Wrapper memory\n");
+ return -EIO;
+ }
+
+ /* Set up interrupt */
+ write_reg(priv->wrapper_addr, ISPINT_ENABLE, 0);
+ write_reg(priv->wrapper_addr, ISPERR0_ENABLE, 0);
+ uio_info->irq = irq_of_parse_and_map(pdev->dev.of_node, 1);
+ if (uio_info->irq == -ENXIO) {
+ dev_err(dev, "failed to parse ISP Wrapper interrupt\n");
+ return -EINVAL;
+ }
+ uio_info->handler = isp_wrapper_irq_handler;
+ uio_info->irqcontrol = irq_control;
+
+ /* Register the UIO device */
+ if ((err = uio_register_device(dev, uio_info))) {
+ dev_err(dev, "failed to register UIO device for ISP Wrapper\n");
+ return err;
+ }
+
+ /* Register this uio_info with the platform data */
+ uio_info->priv = priv;
+ priv->uio_info[1] = uio_info;
+ spin_lock_init(&priv->wrapper_lock);
+ priv->wrapper_flags = 1; /* The ISP Wrapper interrupt is active */
+
+ /* Print some information */
+ dev_dbg(dev, "ISP Wrapper irq %ld\n", uio_info->irq);
+
+ return 0;
+}
+
+static int isp_wrapper_open(struct uio_info *uio_info, struct inode *inode)
+{
+ struct uio_isp_platform_data *priv = uio_info->priv;
+
+ dev_dbg(&priv->pdev->dev, "isp wrapper open\n");
+
+ return 0;
+}
+
+static int isp_wrapper_close(struct uio_info *uio_info, struct inode *inode)
+{
+ struct uio_isp_platform_data *priv = uio_info->priv;
+
+ dev_dbg(&priv->pdev->dev, "isp wrapper close\n");
+
+ return 0;
+}
+
+static irqreturn_t isp_wrapper_irq_handler(int irq, struct uio_info *uio_info)
+{
+ struct uio_isp_platform_data *priv = uio_info->priv;
+ u32 ispint_status = read_reg(priv->wrapper_addr, ISPINT_STATUS);
+
+ /* Mask all interrupts */
+ write_reg(priv->wrapper_addr, ISPINT_ENABLE, 0);
+
+ if (!ispint_status)
+ return IRQ_NONE;
+
+ return IRQ_HANDLED;
+}
+
+static int isp_probe(struct platform_device *pdev, struct uio_isp_platform_data * const priv)
+{
+ struct uio_info *uio_info;
+ struct uio_mem *uio_mem;
+ struct resource *res;
+ int err;
+ struct device *dev = &pdev->dev;
+
+ /* Construct the uio_info structure */
+ uio_info = devm_kzalloc(dev, sizeof(*uio_info), GFP_KERNEL);
+ if (!uio_info)
+ return -ENOMEM;
+ uio_info->version = DRIVER_VERSION;
+ uio_info->open = isp_open;
+ uio_info->release = isp_close;
+ uio_info->name = pdev->name;
+
+ /* Set up memory resource */
+ uio_mem = &uio_info->mem[0];
+ res = platform_get_resource(pdev, IORESOURCE_MEM, 0);
+ if (!res) {
+ dev_err(dev, "failed to get ISP memory\n");
+ return -EINVAL;
+ }
+ uio_mem->memtype = UIO_MEM_PHYS;
+ uio_mem->addr = res->start;
+ uio_mem->size = resource_size(res);
+ uio_mem->name = res->name;
+ if (!devm_request_mem_region(dev, res->start, resource_size(res), uio_info->name)) {
+ dev_err(dev, "failed to reserve ISP memory\n");
+ return -ENOMEM;
+ }
+ priv->base_addr = devm_ioremap_nocache(dev, res->start, resource_size(res));
+ if (!priv->base_addr) {
+ dev_err(dev, "failed to map ISP memory\n");
+ return -EIO;
+ }
+
+ /* Set up interrupt */
+ write_reg(priv->base_addr, ISP_INT_FRAME_START_MASK, 0);
+ write_reg(priv->base_addr, ISP_INT_FRAME_END_MASK, 0);
+ write_reg(priv->base_addr, ISP_INT_STATS_MASK, 0);
+ uio_info->irq = irq_of_parse_and_map(pdev->dev.of_node, 0);
+ if (uio_info->irq == -ENXIO) {
+ dev_err(dev, "failed to parse ISP interrupt\n");
+ return -EINVAL;
+ }
+ uio_info->handler = isp_irq_handler;
+ uio_info->irqcontrol = irq_control;
+
+ /* Set up clock */
+ priv->isp_clock = devm_clk_get(dev, NULL);
+ if (IS_ERR(priv->isp_clock)) {
+ dev_err(dev, "failed to get ISP clock info\n");
+ return -ENODEV;
+ }
+
+ /* Register the UIO device */
+ if ((err = uio_register_device(dev, uio_info))) {
+ dev_err(dev, "failed to register UIO device for ISP\n");
+ return err;
+ }
+
+ /* Register the uio_info with the platform data */
+ uio_info->priv = priv;
+ priv->uio_info[0] = uio_info;
+ spin_lock_init(&priv->isp_lock);
+ priv->isp_flags = 1; /* ISP interrupt is active */
+
+ /* Register the UIO device with the PM framework */
+ pm_runtime_enable(dev);
+
+ /* Enable clocks */
+ if ((err = clk_prepare_enable(priv->isp_clock))) {
+ dev_err(dev, "failed to enable clock\n");
+ return -EBUSY;
+ }
+
+ /* Print some information */
+ dev_dbg(dev, "ISP irq %ld clock %ld Hz\n", uio_info->irq, clk_get_rate(priv->isp_clock));
+
+ return 0;
+}
+
+static int isp_open(struct uio_info *uio_info, __attribute__((unused)) struct inode *inode)
+{
+ struct uio_isp_platform_data *priv = uio_info->priv;
+
+ dev_dbg(&priv->pdev->dev, "isp open\n");
+ /* Wait until the PM has woken up the device */
+ pm_runtime_get_sync(&priv->pdev->dev);
+
+ if (!test_and_set_bit(0, &priv->isp_flags))
+ enable_irq((unsigned int)uio_info->irq);
+
+ return 0;
+}
+
+static int isp_close(struct uio_info *uio_info, __attribute__((unused)) struct inode *inode)
+{
+ struct uio_isp_platform_data *priv = uio_info->priv;
+
+ dev_dbg(&priv->pdev->dev, "isp close\n");
+ /* Tell the PM that the device has become idle */
+ pm_runtime_put_sync(&priv->pdev->dev);
+
+ if (test_and_clear_bit(0, &priv->isp_flags))
+ disable_irq((unsigned int)uio_info->irq);
+
+ return 0;
+}
+
+static irqreturn_t isp_irq_handler(int irq, struct uio_info *uio_info)
+{
+ struct uio_isp_platform_data *priv = uio_info->priv;
+ u32 fstart_status;
+ u32 fend_status;
+ u32 stats_status;
+
+ /* Mask all interrupts, umask by user process */
+ write_reg(priv->base_addr, ISP_INT_FRAME_START_MASK, 0);
+ write_reg(priv->base_addr, ISP_INT_FRAME_END_MASK, 0);
+ write_reg(priv->base_addr, ISP_INT_STATS_MASK, 0);
+
+ fstart_status = read_reg(priv->base_addr, ISP_INT_FRAME_START_STATUS);
+ fend_status = read_reg(priv->base_addr, ISP_INT_FRAME_END_STATUS);
+ stats_status = read_reg(priv->base_addr, ISP_INT_STATS_STATUS);
+
+ if (!(fstart_status | fend_status | stats_status)) {
+ return IRQ_NONE;
+ }
+
+ return IRQ_HANDLED;
+}
+
+static int irq_control(struct uio_info *uio_info, s32 irq_on)
+{
+ struct uio_isp_platform_data *const priv = uio_info->priv;
+ unsigned long flag;
+
+ if (uio_info == priv->uio_info[0]) {
+ dev_dbg(&priv->pdev->dev, "ISP irq_control\n");
+ /* This is the ISP */
+ spin_lock_irqsave(&priv->isp_lock, flag);
+ if (irq_on) {
+ if (!test_and_set_bit(0, &priv->isp_flags)) {
+ enable_irq((unsigned int)uio_info->irq);
+ }
+ }
+ else {
+ if (test_and_clear_bit(0, &priv->isp_flags)) {
+ disable_irq((unsigned int)uio_info->irq);
+ }
+ }
+ spin_unlock_irqrestore(&priv->isp_lock, flag);
+ } else {
+ dev_dbg(&priv->pdev->dev, "ISP Wrapper irq_control\n");
+ /* This is the ISP Wrapper */
+ spin_lock_irqsave(&priv->wrapper_lock, flag);
+ if (irq_on) {
+ if (!test_and_set_bit(0, &priv->wrapper_flags)) {
+ enable_irq((unsigned int)uio_info->irq);
+ }
+ }
+ else {
+ if (test_and_clear_bit(0, &priv->wrapper_flags)) {
+ disable_irq((unsigned int)uio_info->irq);
+ }
+ }
+ spin_unlock_irqrestore(&priv->wrapper_lock, flag);
+ }
+
+ return 0;
+}
+
+static int uio_isp_probe(struct platform_device *pdev)
+{
+ struct uio_isp_platform_data *priv;
+ int err;
+
+ /* Allocate memory for the common housekeeping structure */
+ priv = devm_kzalloc(&pdev->dev, sizeof(*priv), GFP_KERNEL);
+ if (!priv)
+ return -ENOMEM;
+ priv->pdev = pdev;
+
+ if ((err = isp_wrapper_probe(pdev, priv)))
+ return err;
+ if ((err = isp_probe(pdev, priv)))
+ return err;
+
+ platform_set_drvdata(pdev, priv);
+
+ return 0;
+}
+
+static int uio_isp_remove(struct platform_device *pdev)
+{
+ struct uio_isp_platform_data *priv = platform_get_drvdata(pdev);
+
+ uio_unregister_device(priv->uio_info[0]);
+ uio_unregister_device(priv->uio_info[1]);
+
+ clk_disable_unprepare(priv->isp_clock);
+ pm_runtime_disable(&priv->pdev->dev);
+
+ platform_set_drvdata(pdev, NULL);
+
+ return 0;
+}
+
+/* Power management */
+static int uio_runtime_isp_nop(__attribute__((unused)) struct device *dev)
+{
+ return 0;
+};
+
+static const struct dev_pm_ops uio_dev_pm_isp_ops =
+{
+ .runtime_suspend = &uio_runtime_isp_nop,
+ .runtime_resume = &uio_runtime_isp_nop,
+};
+
+/* Compatible table */
+static const struct of_device_id rcar_isp_dt_ids[] =
+{
+ { .compatible = "renesas,isp-r8a7797", .data = 0 },
+ { .compatible = "renesas,isp-r8a7798", .data = 0 },
+ {},
+};
+MODULE_DEVICE_TABLE(of, rcar_isp_dt_ids);
+
+/* Platform driver structure */
+static struct platform_driver uio_isp_platform_driver =
+{
+ .probe = &uio_isp_probe,
+ .remove = &uio_isp_remove,
+ .driver =
+ {
+ .name = DRIVER_NAME,
+ .owner = THIS_MODULE,
+ .pm = &uio_dev_pm_isp_ops,
+ .of_match_table = of_match_ptr(rcar_isp_dt_ids)
+ }
+};
+module_platform_driver(uio_isp_platform_driver);
+
+MODULE_AUTHOR("Renesas Electronics Corporation");
+MODULE_DESCRIPTION("Userspace I/O driver for ISP");
+MODULE_LICENSE("Dual MIT/GPL");
+MODULE_ALIAS("platform:" DRIVER_NAME);
diff --git a/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/kernel-module-uio-isp_0.1.bb b/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/kernel-module-uio-isp_0.1.bb
new file mode 100644
index 0000000..ed3a742
--- /dev/null
+++ b/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/kernel-module-uio-isp_0.1.bb
@@ -0,0 +1,27 @@
+SUMMARY = "ISP UIO Driver Module"
+LICENSE = "GPLv2 & MIT"
+LIC_FILES_CHKSUM = " \
+ file://GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \
+ "
+
+inherit module
+
+PR = "r0"
+PV = "0.1"
+
+SRC_URI = " \
+ file://Makefile \
+ file://uio_isp.c \
+ file://GPL-COPYING \
+ file://MIT-COPYING \
+ "
+
+S = "${WORKDIR}"
+
+KERNEL_MODULE_AUTOLOAD += "uio_isp"
+KERNEL_MODULE_PROBECONF += "uio_isp"
+
+module_conf_uio_isp = ""
+module_conf_uio_isp_r8a7795 = "options uio_isp clear_int"
+module_conf_uio_isp_r8a7796 = "options uio_isp clear_int"