aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephane Desneux <stephane.desneux@iot.bzh>2019-03-14 14:47:29 +0000
committerStephane Desneux <stephane.desneux@iot.bzh>2019-04-04 18:16:28 +0200
commit71ff8ddf13b5efc890ea5832a86f954aa9d799d7 (patch)
tree4f86e93ce36ab7c4aab95d20c88c8ce08bb199c2
parent696363772c9c27f7705187837e96a135d9930854 (diff)
[COMMUNITY] optee-os: fix dummy git config
In new BSP 3.15, optee-os recipe now does some tricks with git repositories in do_configure. But if git is not configured for the current user, do_configure may fail and break the build. This patch adds a workaround by adding a fake identity to the current user. Bug-AGL: SPEC-2265 Change-Id: I14530e2e23cbcd5bc3b2f71fd93900be95d7dd60 Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
index 35c043f..d8365dd 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
@@ -40,6 +40,8 @@ S = "${WORKDIR}/git"
EXTRA_OEMAKE = "-e MAKEFLAGS="
do_configure() {
+ git -C ${WORKDIR}/git_official config --local user.name "AGL Git User"
+ git -C ${WORKDIR}/git_official config --local user.email agl@none.null
git -C ${WORKDIR}/git_official checkout -B official 3.1.0
git -C ${WORKDIR}/git_official cherry-pick ${SRCREV_officialgit}
cp -rn ${WORKDIR}/git_official/core/lib/libtomcrypt ${B}/core/lib/.