aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@renesas.com>2019-02-14 15:23:08 +0700
committerThuy Tran <thuy.tran.xh@renesas.com>2019-02-28 09:43:53 +0700
commit84d5c396d5e91c3f81c243578ebaaf5abf398ffe (patch)
treeda267424f270ee1f676232f5822b0a3596eb799e
parentd6c2c6c31ea7680ee843eeba08269e82431a61d7 (diff)
rcar-gen3: weston: WORKAROUND to fix playing video issues
This commit applies a W/A patch to disable HW overlay feature in weston 5.0, to avoid playing video issues. Signed-off-by: Thuy Tran <thuy.tran.xh@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston/0001-Revert-compositor-drm-Enable-planes-for-atomic.patch53
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend6
2 files changed, 59 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston/0001-Revert-compositor-drm-Enable-planes-for-atomic.patch b/meta-rcar-gen3/recipes-graphics/wayland/weston/0001-Revert-compositor-drm-Enable-planes-for-atomic.patch
new file mode 100644
index 0000000..cfbf424
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston/0001-Revert-compositor-drm-Enable-planes-for-atomic.patch
@@ -0,0 +1,53 @@
+From 2fe71354686408b0d1c2833442b6b160b5c92809 Mon Sep 17 00:00:00 2001
+From: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
+Date: Thu, 14 Feb 2019 14:05:35 +0900
+Subject: [PATCH] Revert "compositor-drm: Enable planes for atomic"
+
+This reverts commit 678aabe829371d48af00e718f4a41185a3d50f1f.
+---
+ libweston/compositor-drm.c | 22 +++++++++++-----------
+ 1 file changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/libweston/compositor-drm.c b/libweston/compositor-drm.c
+index 3891176..07acab7 100644
+--- a/libweston/compositor-drm.c
++++ b/libweston/compositor-drm.c
+@@ -3822,17 +3822,6 @@ init_kms_caps(struct drm_backend *b)
+ weston_log("DRM: %s atomic modesetting\n",
+ b->atomic_modeset ? "supports" : "does not support");
+
+- /*
+- * KMS support for hardware planes cannot properly synchronize
+- * without nuclear page flip. Without nuclear/atomic, hw plane
+- * and cursor plane updates would either tear or cause extra
+- * waits for vblanks which means dropping the compositor framerate
+- * to a fraction. For cursors, it's not so bad, so they are
+- * enabled.
+- */
+- if (!b->atomic_modeset)
+- b->sprites_are_broken = 1;
+-
+ ret = drmSetClientCap(b->drm.fd, DRM_CLIENT_CAP_ASPECT_RATIO, 1);
+ b->aspect_ratio_supported = (ret == 0);
+ weston_log("DRM: %s picture aspect ratio\n",
+@@ -6716,6 +6705,17 @@ drm_backend_create(struct weston_compositor *compositor,
+ b->drm.fd = -1;
+ wl_array_init(&b->unused_crtcs);
+
++ /*
++ * KMS support for hardware planes cannot properly synchronize
++ * without nuclear page flip. Without nuclear/atomic, hw plane
++ * and cursor plane updates would either tear or cause extra
++ * waits for vblanks which means dropping the compositor framerate
++ * to a fraction. For cursors, it's not so bad, so they are
++ * enabled.
++ *
++ * These can be enabled again when nuclear/atomic support lands.
++ */
++ b->sprites_are_broken = 1;
+ b->compositor = compositor;
+ b->use_pixman = config->use_pixman;
+ b->pageflip_timeout = config->pageflip_timeout;
+--
+2.9.2
+
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
index 34ea2c9..15471b7 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
@@ -1 +1,7 @@
require weston.inc
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append = " \
+ file://0001-Revert-compositor-drm-Enable-planes-for-atomic.patch \
+"