aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@renesas.com>2018-08-10 11:16:23 +0700
committerDuy Dang <duy.dang.yw@rvc.renesas.com>2018-10-26 09:45:37 +0700
commitad00bae67aaa4366d0cb97a8c676ab94fb9b250e (patch)
tree8de5475dc5b8cd993713a577922c023750ae50a3
parent17df773447dfcc44a076d42081dc05d4fda125d4 (diff)
rcar-gen3: base-files: Do not override LD_LIBRARY_PATH variable
This commit modifies recipe to avoid overriding LD_LIBRARY_PATH environment variable. Signed-off-by: Thuy Tran <thuy.tran.xh@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-core/base-files/base-files_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-rcar-gen3/recipes-core/base-files/base-files_%.bbappend b/meta-rcar-gen3/recipes-core/base-files/base-files_%.bbappend
index ffec1e1..3381aa5 100644
--- a/meta-rcar-gen3/recipes-core/base-files/base-files_%.bbappend
+++ b/meta-rcar-gen3/recipes-core/base-files/base-files_%.bbappend
@@ -1,5 +1,5 @@
require include/rcar-gen3-path-common.inc
do_install_append () {
- echo "export LD_LIBRARY_PATH=\"${RENESAS_DATADIR}/lib\"" >> ${D}${sysconfdir}/profile
+ echo "export LD_LIBRARY_PATH=\"\${LD_LIBRARY_PATH}:${RENESAS_DATADIR}/lib\"" >> ${D}${sysconfdir}/profile
}