aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@renesas.com>2018-07-17 17:48:52 +0700
committerThuy Tran <thuy.tran.xh@renesas.com>2019-02-28 09:43:53 +0700
commitafdbef77d3f4e13bd71c404181b924ffe2227edd (patch)
treeb10eda48d08d0e75dfd0c0a75603df61402500ea
parentbd6246990c4549a07e1d7e924093dc809cb8a306 (diff)
rcar-gen3: optee-client: WORKAROUND to build with GCC 8.1
This commit applies a W/A patch from optee upstream to fix GCC 8 format-truncation errors. [1] https://github.com/OP-TEE/optee_client/issues/126 Signed-off-by: Thuy Tran <thuy.tran.xh@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Fix-for-teec_trace.c-snprintf-Werror-format-truncati.patch28
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb1
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Fix-for-teec_trace.c-snprintf-Werror-format-truncati.patch b/meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Fix-for-teec_trace.c-snprintf-Werror-format-truncati.patch
new file mode 100644
index 0000000..db8bdac
--- /dev/null
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Fix-for-teec_trace.c-snprintf-Werror-format-truncati.patch
@@ -0,0 +1,28 @@
+From 30dd2986fb64aba7ee78d4e231c344e2c39d7999 Mon Sep 17 00:00:00 2001
+From: Simon Hughes <simon.hughes@arm.com>
+Date: Thu, 21 Jun 2018 17:22:23 +0100
+Subject: [PATCH] Fix for teec_trace.c snprintf -Werror=format-truncation=
+ error.
+
+Signed-off-by: Simon Hughes <simon.hughes@arm.com>
+---
+ libteec/src/teec_trace.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/libteec/src/teec_trace.c b/libteec/src/teec_trace.c
+index 78b79d6..c91bc43 100644
+--- a/libteec/src/teec_trace.c
++++ b/libteec/src/teec_trace.c
+@@ -106,7 +106,8 @@ int _dprintf(const char *function, int flen, int line, int level,
+ */
+ int thread_id = syscall(SYS_gettid); /* perf issue ? */
+
+- snprintf(prefixed, MAX_PRINT_SIZE,
++ int len = 0;
++ len = snprintf(prefixed+len, MAX_PRINT_SIZE,
+ "%s [%d] %s:%s:%d: %s",
+ trace_level_strings[level], thread_id, prefix, func,
+ line, raw);
+--
+2.7.4
+
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb
index 2105900..727e8d5 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb
@@ -10,6 +10,7 @@ SRCREV = "3f16662284a69fdec97b1712064be94d1fed7ae7"
SRC_URI += " \
file://optee.service \
+ file://0001-Fix-for-teec_trace.c-snprintf-Werror-format-truncati.patch \
"
inherit pythonnative systemd