aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@renesas.com>2018-07-17 18:23:40 +0700
committerThuy Tran <thuy.tran.xh@renesas.com>2019-02-28 09:43:53 +0700
commitbd6246990c4549a07e1d7e924093dc809cb8a306 (patch)
tree82f926ae3bab3c7e1d070dd02662a5fa6939510f
parent0311c6b1a02611971c9ed5a18fb5ce0fe21c5e22 (diff)
rcar-gen3: optee-os: WORKAROUND to build with GCC 8.1
This commit adds NOWERROR=1 to ignore GCC 8 cast-function-type build errors for SYSCALL_ENTRY() [1]. | core/arch/arm/tee/arch_svc.c:47:36: error: cast between incompatible function types from 'void (*)(long unsigned in| t)' to 'TEE_Result (*)(void)' {aka 'unsigned int (*)(void)'} [-Werror=cast-function-type] | #define SYSCALL_ENTRY(_fn) { .fn = (syscall_t)_fn } ^ | core/arch/arm/tee/arch_svc.c:54:2: note: in expansion of macro 'SYSCALL_ENTRY' | SYSCALL_ENTRY(syscall_sys_return), | ^~~~~~~~~~~~~ | core/arch/arm/tee/arch_svc.c:47:36: error: cast between incompatible function types from 'void (*)(const void *, si| ze_t)' {aka 'void (*)(const void *, long unsigned int)'} to 'TEE_Result (*)(void)' {aka 'unsigned int (*)(void)'} [| -Werror=cast-function-type] | #define SYSCALL_ENTRY(_fn) { .fn = (syscall_t)_fn } ^ | core/arch/arm/tee/arch_svc.c:55:2: note: in expansion of macro 'SYSCALL_ENTRY' | SYSCALL_ENTRY(syscall_log), | ^~~~~~~~~~~~~ [1] https://github.com/OP-TEE/optee_os/issues/2393 Signed-off-by: Thuy Tran <thuy.tran.xh@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
index c0be969..35c043f 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
@@ -46,7 +46,7 @@ do_configure() {
}
do_compile() {
- oe_runmake PLATFORM=${PLATFORM} CFG_ARM64_core=y
+ oe_runmake PLATFORM=${PLATFORM} CFG_ARM64_core=y NOWERROR=1
}
# do_install() nothing