aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@renesas.com>2018-10-29 17:03:17 +0900
committerThuy Tran <thuy.tran.xh@renesas.com>2019-02-28 09:43:53 +0700
commitd6c2c6c31ea7680ee843eeba08269e82431a61d7 (patch)
tree1bf14e6a4ebbee8ec73271fda65c75703ee1de76
parente46d6a91dc9e8f0383aa604878ec2d8db04a85ce (diff)
rcar-gen3: weston: Split out machine specific configuration
This commit adds more weston-conf bbappend to adapt YP2.6. Renesas MACHINEs also provided their configurations. (From Poky rev: 4001e1adb21b9785a19669968f07166f5b8772cd) Signed-off-by: Thuy Tran <thuy.tran.xh@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend34
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston-conf/weston.ini (renamed from meta-rcar-gen3/recipes-graphics/wayland/weston/weston.ini)0
-rwxr-xr-xmeta-rcar-gen3/recipes-graphics/wayland/weston-conf/weston.sh (renamed from meta-rcar-gen3/recipes-graphics/wayland/weston/weston.sh)0
-rw-r--r--meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend36
4 files changed, 34 insertions, 36 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend
new file mode 100644
index 0000000..179651b
--- /dev/null
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston-conf.bbappend
@@ -0,0 +1,34 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI = " \
+ file://weston.ini \
+ file://weston.sh \
+"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/xdg/weston
+ # install weston.ini as sample settings of gl-renderer
+ install -m 644 ${WORKDIR}/weston.ini ${D}/${sysconfdir}/xdg/weston/
+
+ # Checking for ivi-shell configuration
+ # If ivi-shell is enable, we will add its configs to weston.ini
+ if [ "X${USE_WAYLAND_IVI_SHELL}" = "X1" ]; then
+ sed -i '/repaint-window=34/c\repaint-window=34\nshell=ivi-shell.so' \
+ ${D}/${sysconfdir}/xdg/weston/weston.ini
+ sed -e '$a\\' \
+ -e '$a\[ivi-shell]' \
+ -e '$a\ivi-module=ivi-controller.so' \
+ -e '$a\ivi-input-module=ivi-input-controller.so' \
+ -e '$a\transition-duration=300' \
+ -e '$a\cursor-theme=default' \
+ -i ${D}/${sysconfdir}/xdg/weston/weston.ini
+ fi
+
+ # Set XDG_RUNTIME_DIR to /run/user/$UID (e.g. run/user/0)
+ install -d ${D}/${sysconfdir}/profile.d
+ install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
+}
+
+FILES_${PN}_append = " \
+ ${sysconfdir}/profile.d/weston.sh \
+"
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston/weston.ini b/meta-rcar-gen3/recipes-graphics/wayland/weston-conf/weston.ini
index f31c290..f31c290 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston/weston.ini
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston-conf/weston.ini
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston/weston.sh b/meta-rcar-gen3/recipes-graphics/wayland/weston-conf/weston.sh
index 33ed8a4..33ed8a4 100755
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston/weston.sh
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston-conf/weston.sh
diff --git a/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend b/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
index 18ed8ce..34ea2c9 100644
--- a/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-rcar-gen3/recipes-graphics/wayland/weston_%.bbappend
@@ -1,37 +1 @@
require weston.inc
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI_append = " \
- file://weston.ini \
- file://weston.sh \
-"
-
-do_install_append() {
- install -d ${D}/${sysconfdir}/xdg/weston
- # install weston.ini as sample settings of gl-renderer
- install -m 644 ${WORKDIR}/weston.ini ${D}/${sysconfdir}/xdg/weston/
-
- # Checking for ivi-shell configuration
- # If ivi-shell is enable, we will add its configs to weston.ini
- if [ "X${USE_WAYLAND_IVI_SHELL}" = "X1" ]; then
- sed -i '/repaint-window=34/c\repaint-window=34\nshell=ivi-shell.so' \
- ${D}/${sysconfdir}/xdg/weston/weston.ini
- sed -e '$a\\' \
- -e '$a\[ivi-shell]' \
- -e '$a\ivi-module=ivi-controller.so' \
- -e '$a\ivi-input-module=ivi-input-controller.so' \
- -e '$a\transition-duration=300' \
- -e '$a\cursor-theme=default' \
- -i ${D}/${sysconfdir}/xdg/weston/weston.ini
- fi
-
- # Set XDG_RUNTIME_DIR to /run/user/$UID (e.g. run/user/0)
- install -d ${D}/${sysconfdir}/profile.d
- install -m 0755 ${WORKDIR}/weston.sh ${D}/${sysconfdir}/profile.d/weston.sh
-}
-
-FILES_${PN}_append = " \
- ${sysconfdir}/xdg/weston/weston.ini \
- ${sysconfdir}/profile.d/weston.sh \
-"