aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThao Nguyen <thao.nguyen.yb@renesas.com>2017-07-12 15:39:12 +0700
committerThao Nguyen <thao.nguyen.yb@renesas.com>2017-08-25 08:29:31 +0700
commit9da249f633f29635ba0a1c806898b83ff34f3b05 (patch)
tree47192179f63cfaa73ddeabb053c70e1912d50385
parent85b786501fc4a52af91cf37b9cfbd06b6efc53ea (diff)
rcar-gen3: linux-renesas: linux-renesas: Upgrade Linux BSP from v3.5.5 to v3.5.8
Linux BSP has been upgraded for following changes: v3.5.8 [Audio driver] - Fix S2R issue. [DMA Engine driver] - Fix S2R issue. [USB2.0 Function] - Fix lock variable no init [USB Host 3.0] - Fix support for R-Car Gen3 USB 3.0 PHY. v3.5.7 [DMA Engine driver] - Fix the missing spin_unlock_irqrestore. [Display driver] - Fix unload procedure for vsp1. v3.5.6 [Kernel core] - Add next-level-cache property to CA53. - Add 12288000 for sound ADG or fix descending order of sound clock frequency to device tree. - Fix the audio pingroup name mismatch between sh-pfc driver and dts to device tree. [Power Management] - Change the reading AVS value method. - AVS7 opp table to device tree. - The resume function for SYSC driver and always turn on all power domains except CPU and GPU. - Change sequence for judgement using fixed values or Fuse values. [Audio driver] - There are sampling rate patterns that can not be converted by combination of audio clock and AK4613. It was confirmed this is a board specifications. However, they can be converted via alsalib. - Control kctrl items acceptance anytime/runtime. - SSI PIO adjust to 24bit mode. - Unsupport 64kHz sampling rate and more with AK4613 on Salvator-X/XS board. [Display driver] - Setup planes before enabling CRTC to avoid flicker. - Use DRM core's atomic commit helper. - Fix display list put for header mode. - Repair vblank for DRM page flips using the VSP1. - Wait for flip completion instead of vblank in commit tail. - Fix completed check in write back sequence. - Fix display starting procedure and DPLL clock divider judgement. [PTP Clock driver] - Fix interrupt cause bit overwrite in ravb_ptp_interrupt. - Fix result value overwrite by a return value of ravb_ptp_interrupt(). - Fix inconsistent lock state at enabling tx timestamp. [SATA driver] - Fix blk_get_backing_dev_info() crash using bdev->bd_queue, so kernel panic can be avoided in case of high load average. [DMA Engine driver] - Fix invalid context of sleeping function. - Fix inconsistent lock reported by PROVE_LOCKING. [SD/MMC] - Add SDHI-SEQUENCER support. This is Workaround for SDHI-DMAC restriction of R-Car H3 Ver.1.x and R-Car M3 Ver.1.0. - Wait for CBSY instead of SCLKDIVEN. - Disable msleep() at start/stop of SD clock. - Discard obsolete SDIO irqs before enabling irqs. - Relax checking for switch errors after HS200 switch. - Replace msleep() of 20ms or less with usleep_range(). - Fix to use pre_req and post_req only for DMA transfer. - Fix alignment check of sg buffer. [USB2.0 Function] - Fix return value of usbhsg_ep_disable(), so the suspend procedure works when the g_mass_storage enables. - Fix NULL packet received sequence. - Fix UGCTRL2 value for R-Car Gen3. [USB3.0 Function] - Protect usb3_ep->started in usb3_start_pipen(), so kernel panic does not occur when executing iperf with g_ncm. - Confirm an error does not occur when executing interrupt transfer with g_zero by correcting evaluation procedure. - Confirm g_mass_storage is recognized by Host PC after role swap. Please use USB 2.0 cable, because role swap is compatible with High-Speed. - Fix free size in renesas_usb3_dma_free_prd(). - Fix zlp transfer by the dmac. - Fix pm_runtime_enable/disable and add CONFIG_PM_SLEEP to suspend/resume functions. [PCIe driver] - PCIe of R-Car Gen3 can access only 32 bit memory area at a certain point, even if using IPMMU. This is a H/W specifications. Signed-off-by: Thao Nguyen <thao.nguyen.yb@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb4
-rw-r--r--meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb
index 81a70b8..421e8ed 100644
--- a/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux-libc-headers/linux-libc-headers_4.9.bb
@@ -2,8 +2,8 @@ require recipes-kernel/linux-libc-headers/linux-libc-headers.inc
RENESAS_BSP_URL = " \
git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.9/rcar-3.5.5"
-SRCREV = "58e9b7349e1a28f2ef830f9164112fb17ba31426"
+BRANCH = "v4.9/rcar-3.5.8"
+SRCREV = "bef6058b0ba00238b19e7518ba76536218ef97f1"
SRC_URI = "${RENESAS_BSP_URL};branch=${BRANCH}"
diff --git a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb
index 88a963f..9207cdd 100644
--- a/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb
+++ b/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_4.9.bb
@@ -7,8 +7,8 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
COMPATIBLE_MACHINE = "salvator-x|h3ulcb|m3ulcb"
RENESAS_BSP_URL = "git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas-bsp.git"
-BRANCH = "v4.9/rcar-3.5.5"
-SRCREV = "58e9b7349e1a28f2ef830f9164112fb17ba31426"
+BRANCH = "v4.9/rcar-3.5.8"
+SRCREV = "bef6058b0ba00238b19e7518ba76536218ef97f1"
SRC_URI = "${RENESAS_BSP_URL};protocol=git;nocheckout=1;branch=${BRANCH}"