aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Lawrence <stephen.lawrence@renesas.com>2017-04-21 16:33:03 +0100
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2018-01-30 10:07:59 +0700
commitbab2a0118b76ff7aa82fa246e6503e9887fde86d (patch)
tree52cb464e53d110a28a28790e0e35dde21d3bcdc7
parentf7f6d2cad69f728769defd6e985349e437953798 (diff)
rcar-gen3: omx-user-module: Correct build tree setup for YP 2.2 morty
The change directory parameter of the tar utility acts on the parameters that follow it. Correct the ordering so that the setup_build_tree() task extracts the omx tar balls to the right location. Fixes a build error that would otherwise occur in yp 2.2 morty. (cherry picked from commit 9f0211bafb118e81ec2fd6dd82b5777964b1ac9b) Signed-off-by: Stephen Lawrence <stephen.lawrence@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-multimedia/omx-module/omx-user-module.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-rcar-gen3/recipes-multimedia/omx-module/omx-user-module.bb b/meta-rcar-gen3/recipes-multimedia/omx-module/omx-user-module.bb
index 08ea7b1..d0da0f7 100644
--- a/meta-rcar-gen3/recipes-multimedia/omx-module/omx-user-module.bb
+++ b/meta-rcar-gen3/recipes-multimedia/omx-module/omx-user-module.bb
@@ -157,8 +157,8 @@ setup_build_tree() {
for omxmc in ${OMX_COMMON_SRC} ${OMX_VIDEO_DEC_COMMON_SRC} ${OMX_VIDEO_ENC_COMMON_SRC}
do
tar xf ${WORKDIR}/${omxmc}.tar.bz2 -C ${WORKDIR}
- tar xf ${WORKDIR}/${omxmc}.tar.bz2 ${omxmc}/src --strip=2 -C ${S}
- tar xf ${WORKDIR}/${omxmc}.tar.bz2 ${omxmc}/include --strip=1 -C ${S}
+ tar xf ${WORKDIR}/${omxmc}.tar.bz2 -C ${S} ${omxmc}/src --strip=2
+ tar xf ${WORKDIR}/${omxmc}.tar.bz2 -C ${S} ${omxmc}/include --strip=1
done
}