aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThao Nguyen <thao.nguyen.yb@renesas.com>2017-09-12 11:11:47 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2018-01-30 10:07:59 +0700
commitc13886b9701dfb7e41a66115aeda8cc3a1c80188 (patch)
tree3d6c2750891b2d40ee5cf5e9bc0e3cf88b3d28d6
parent8022516a67679cab05ba10a6f19399598e181015 (diff)
rcar-gen3: kernel-module-vspm: Add deploy/licenses into cleaned dir
When switch between different machines (i.e. salvator-x and h3ulcb), we can meet below issue: ERROR: kernel-module-vspm-1.0-r0 do_populate_lic: The recipe kernel-module-vspm is trying to install files into a shared area when those files already exist. Those files and their manifest location are: /ssd/FS_YP2.4/build_mmp/h3ulcb-build/tmp/deploy/licenses/kernel-module-vspm/generic_MIT (matched in manifest-salvator_x-kernel-module-vspm.populate_lic) /ssd/FS_YP2.4/build_mmp/h3ulcb-build/tmp/deploy/licenses/kernel-module-vspm/recipeinfo (matched in manifest-salvator_x-kernel-module-vspm.populate_lic) /ssd/FS_YP2.4/build_mmp/h3ulcb-build/tmp/deploy/licenses/kernel-module-vspm/GPL-COPYING (matched in manifest-salvator_x-kernel-module-vspm.populate_lic) /ssd/FS_YP2.4/build_mmp/h3ulcb-build/tmp/deploy/licenses/kernel-module-vspm/MIT-COPYING (matched in manifest-salvator_x-kernel-module-vspm.populate_lic) /ssd/FS_YP2.4/build_mmp/h3ulcb-build/tmp/deploy/licenses/kernel-module-vspm/generic_GPLv2 (matched in manifest-salvator_x-kernel-module-vspm.populate_lic) Please verify which recipe should provide the above files. The reason is the tmp/deploy/licenses/kernel-module-vspm/ has not been cleaned during do_clean task. To avoid it, we should also clean ${LICENSE_DIRECTORY}/${PN} in do_clean. Signed-off-by: Thao Nguyen <thao.nguyen.yb@renesas.com> Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-kernel/kernel-module-vspm/kernel-module-vspm.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-kernel/kernel-module-vspm/kernel-module-vspm.bb b/meta-rcar-gen3/recipes-kernel/kernel-module-vspm/kernel-module-vspm.bb
index 5c2b65e..627dea1 100644
--- a/meta-rcar-gen3/recipes-kernel/kernel-module-vspm/kernel-module-vspm.bb
+++ b/meta-rcar-gen3/recipes-kernel/kernel-module-vspm/kernel-module-vspm.bb
@@ -71,6 +71,10 @@ vspm_sstate_check_func() {
fi
}
+# Should also clean deploy/licenses directory
+# for module when do_clean.
+do_clean[cleandirs] += "${LICENSE_DIRECTORY}/${PN}"
+
PACKAGES = " \
${PN} \
${PN}-dev \