aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/kernel-module-uio-isp_0.1.bb
diff options
context:
space:
mode:
authorAndrey Dolnikov <andrey.dolnikov@cogentembedded.com>2018-04-16 12:07:32 +0300
committerAndrey Dolnikov <andrey.dolnikov@cogentembedded.com>2018-04-16 16:09:15 +0300
commit1e40e21e5dc5da75931ed835c624147d25af4b55 (patch)
tree86bd842146adf32ca7cbe6b98ad9575b174b7406 /meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/kernel-module-uio-isp_0.1.bb
parent4ae3ea734b05c22620e7108885f4d28305ceaae7 (diff)
Add ISP UIO driver.
Diffstat (limited to 'meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/kernel-module-uio-isp_0.1.bb')
-rw-r--r--meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/kernel-module-uio-isp_0.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/kernel-module-uio-isp_0.1.bb b/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/kernel-module-uio-isp_0.1.bb
new file mode 100644
index 0000000..ed3a742
--- /dev/null
+++ b/meta-rcar-gen3-adas/recipes-kernel/kernel-module-uio-isp/kernel-module-uio-isp_0.1.bb
@@ -0,0 +1,27 @@
+SUMMARY = "ISP UIO Driver Module"
+LICENSE = "GPLv2 & MIT"
+LIC_FILES_CHKSUM = " \
+ file://GPL-COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://MIT-COPYING;md5=fea016ce2bdf2ec10080f69e9381d378 \
+ "
+
+inherit module
+
+PR = "r0"
+PV = "0.1"
+
+SRC_URI = " \
+ file://Makefile \
+ file://uio_isp.c \
+ file://GPL-COPYING \
+ file://MIT-COPYING \
+ "
+
+S = "${WORKDIR}"
+
+KERNEL_MODULE_AUTOLOAD += "uio_isp"
+KERNEL_MODULE_PROBECONF += "uio_isp"
+
+module_conf_uio_isp = ""
+module_conf_uio_isp_r8a7795 = "options uio_isp clear_int"
+module_conf_uio_isp_r8a7796 = "options uio_isp clear_int"