aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3-adas/recipes-support
diff options
context:
space:
mode:
authorPetr Nechaev <petr.nechaev@cogentembedded.com>2017-11-22 17:30:36 +0300
committerPetr Nechaev <petr.nechaev@cogentembedded.com>2017-11-22 17:30:36 +0300
commitcfc23e64c7675214f15461a4e533d8ecc2e948f8 (patch)
tree7fae870243c02345344f9ea04a3d10dfaa260d3b /meta-rcar-gen3-adas/recipes-support
parent0b492a5d73c64bbcea5f013c7499bb6551b4a834 (diff)
Fix glog compilation when gflags or gmock are installed on the host machine
Binaries gflags-config and gmock-config are not generated during cross-compilation so use pkg-config instead.
Diffstat (limited to 'meta-rcar-gen3-adas/recipes-support')
-rw-r--r--meta-rcar-gen3-adas/recipes-support/glog/glog-0.3.3/0001-Use-pkg-config-for-locating-gflags-and-gmock.patch44
-rw-r--r--meta-rcar-gen3-adas/recipes-support/glog/glog_0.3.3.bbappend5
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-rcar-gen3-adas/recipes-support/glog/glog-0.3.3/0001-Use-pkg-config-for-locating-gflags-and-gmock.patch b/meta-rcar-gen3-adas/recipes-support/glog/glog-0.3.3/0001-Use-pkg-config-for-locating-gflags-and-gmock.patch
new file mode 100644
index 0000000..7208bfe
--- /dev/null
+++ b/meta-rcar-gen3-adas/recipes-support/glog/glog-0.3.3/0001-Use-pkg-config-for-locating-gflags-and-gmock.patch
@@ -0,0 +1,44 @@
+From ca8570bad0bbefb450a2cbe40c17eb5a5565f829 Mon Sep 17 00:00:00 2001
+From: Petr Nechaev <petr.nechaev@cogentembedded.com>
+Date: Wed, 22 Nov 2017 00:21:45 +0300
+Subject: [PATCH 1/1] Use pkg-config for locating gflags and gmock
+
+Binaries gflags-config and gmock-config are not generated during
+cross-compilation of gflags and gmock so use pkg-config instead.
+---
+ configure.ac | 14 ++++++++------
+ 1 file changed, 8 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 8b458fa..16a6c7e 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -138,17 +138,19 @@ LIBS="$SAVE_LIBS"
+ # TODO(hamaji): Use official m4 macros provided by testing libraries
+ # once the m4 macro of Google Mocking becomes ready.
+ # Check if there is Google Test library installed.
+-AC_CHECK_PROG(GTEST_CONFIG, gtest-config, "yes")
++# Use pkg-config instead of gtest-config with Yocto
++AC_CHECK_PROG(GTEST_CONFIG, pkg-config, "yes")
+ if test x"$GTEST_CONFIG" = "xyes"; then
+- GTEST_CFLAGS=`gtest-config --cppflags --cxxflags`
+- GTEST_LIBS=`gtest-config --ldflags --libs`
++ GTEST_CFLAGS=`pkg-config --cppflags --cxxflags gtest`
++ GTEST_LIBS=`pkg-config --libs gtest`
+ AC_DEFINE(HAVE_LIB_GTEST, 1, [define if you have google gtest library])
+
+ # Check if there is Google Mocking library installed.
+- AC_CHECK_PROG(GMOCK_CONFIG, gmock-config, "yes")
++ # Use pkg-config instead of gmock-config with Yocto
++ AC_CHECK_PROG(GMOCK_CONFIG, pkg-config, "yes")
+ if test x"$GMOCK_CONFIG" = "xyes"; then
+- GMOCK_CFLAGS=`gmock-config --cppflags --cxxflags`
+- GMOCK_LIBS=`gmock-config --ldflags --libs`
++ GMOCK_CFLAGS=`pkg-config --cppflags --cxxflags gmock`
++ GMOCK_LIBS=`pkg-config --libs gmock`
+ AC_DEFINE(HAVE_LIB_GMOCK, 1, [define if you have google gmock library])
+ else
+ # We don't run test cases which use Google Mocking framework.
+--
+2.9.5
+
diff --git a/meta-rcar-gen3-adas/recipes-support/glog/glog_0.3.3.bbappend b/meta-rcar-gen3-adas/recipes-support/glog/glog_0.3.3.bbappend
new file mode 100644
index 0000000..d882ba3
--- /dev/null
+++ b/meta-rcar-gen3-adas/recipes-support/glog/glog_0.3.3.bbappend
@@ -0,0 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}-${PV}:"
+
+SRC_URI_append = " file://0001-Use-pkg-config-for-locating-gflags-and-gmock.patch"
+
+DEPENDS += "gflags gmock"