aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
diff options
context:
space:
mode:
authorMichele Paolino <m.paolino@virtualopensystems.com>2017-05-03 17:48:42 +0200
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-09-15 10:20:15 +0200
commit1d64401097da93773624992e6fe0601f5604d919 (patch)
tree1ce7fad082a898b716ebe0fdfa2615e53b27babc /meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
parentb3ebb30db7b1bd728f09403a5f0806daa654fa1b (diff)
[COMMUNITY] Enable Linux-based hypervisor execution in AGL
The upstream version of AGL boots Linux in EL1. This mode is not privileged enough to put in place the correct configuration of an hypervisor (e.g., KVM). This patch leverages the ATF rcar platform configuration variables to boot the Linux kernel in EL2, instead of EL1, allowing Linux-based hypervisors such as KVM to configure all the necessary stubs to properly run virtual machines. This patch has been successfully tested with ATF, KVM and AGL rootfs on the Renesas R-Car M3. Changelog: - Added arm-trusted-firmware patch, which makes this work easy to be tested by the community - This patch version does not contain Linux kernel modifications. In fact, these resulted not necessary with the proposed ATF patch and a recent kernel (higher than 4.6) Bug-AGL: SPEC-497 Change-Id: I5a22411135b33137cb2236562b3de9c966f1be21 Signed-off-by: Michele Paolino <m.paolino@virtualopensystems.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb')
-rw-r--r--meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb b/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
index 99b5b6a..11ac5ec 100644
--- a/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
@@ -23,6 +23,10 @@ ATFW_OPT_r8a7795 = "LSI=H3 RCAR_DRAM_SPLIT=1 ${ATFW_OPT_LOSSY}"
ATFW_OPT_r8a7796 = "LSI=M3 RCAR_DRAM_SPLIT=2 ${ATFW_OPT_LOSSY}"
ATFW_OPT_append_ulcb = " RCAR_GEN3_ULCB=1 PMIC_LEVEL_MODE=0"
+SRC_URI_append = " \
+ file://0001-Boot-Normal-World-in-EL2.patch \
+"
+
# requires CROSS_COMPILE set by hand as there is no configure script
export CROSS_COMPILE="${TARGET_PREFIX}"