summaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-OPTEE_PROVIDER-188185-Fix-a-contxt-size-allocated-by.patch
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xw@renesas.com>2018-09-03 23:50:35 -0400
committerDuy Dang <duy.dang.yw@rvc.renesas.com>2018-10-19 09:25:15 +0700
commite0272de38ce87f2a9b0e2bac4162d87d11735992 (patch)
tree7e9c97eda270f6991e813742313cf8e9d6220b2a /meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-OPTEE_PROVIDER-188185-Fix-a-contxt-size-allocated-by.patch
parentfea65609a564a85b508a1cb29bbf97c7c9b5bf5f (diff)
rcar-gen3: IPL: Update IPL to the latest version
This commit updates IPL/Secure Monitor for the following changes: Update IPL and Secure Monitor Rev1.0.22 [IPL] - Update CPG setting. - Add support Ebisu-4D board. - Change the timing to invalidate of instruction cache. - Fixed a bug in the exception handler. - Update DDR setting for E3. [Secure Monitor] - Add the wait processing that is placed in the system RAM area for Suspend To RAM. Update optee_os Rev1.0.15 - Fix the polling process of the HyperFlash driver waiting for HW completion. - Fix incorrect memory access in RSA processing using a provider for a HW engine driver. - Fix a conditional branch in a mutex_destroy function. Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Duy Dang <duy.dang.yw@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-OPTEE_PROVIDER-188185-Fix-a-contxt-size-allocated-by.patch')
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-OPTEE_PROVIDER-188185-Fix-a-contxt-size-allocated-by.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-OPTEE_PROVIDER-188185-Fix-a-contxt-size-allocated-by.patch b/meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-OPTEE_PROVIDER-188185-Fix-a-contxt-size-allocated-by.patch
new file mode 100644
index 0000000..eada5c5
--- /dev/null
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-OPTEE_PROVIDER-188185-Fix-a-contxt-size-allocated-by.patch
@@ -0,0 +1,29 @@
+From 88085caf87cf1060c0db269f021efdea617fbef9 Mon Sep 17 00:00:00 2001
+From: Tomohiro Fujiwara <tomohiro.fujiwara.cw@hitachi.com>
+Date: Wed, 26 Sep 2018 10:12:02 +0900
+Subject: [PATCH 1/2] [OPTEE_PROVIDER][#188185] Fix a contxt size allocated by
+ the OP-TEE OS
+
+This commit adds a compile option for deciding a context size used by
+HASH algorithm of SS6.3-Secure Driver.
+
+Signed-off-by: Tomohiro Fujiwara <tomohiro.fujiwara.cw@hitachi.com>
+---
+ core/core.mk | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/core/core.mk b/core/core.mk
+index c428cd00..405b1e76 100644
+--- a/core/core.mk
++++ b/core/core.mk
+@@ -90,6 +90,7 @@ base-prefix :=
+
+ ifeq ($(CFG_CRYPT_HW_CRYPTOENGINE),y)
+ core-platform-cflags += -DENABLE_CRYPTOENGINE
++core-platform-cflags += -DDX_CC_TEE -DCRYS_NO_CRYS_COMBINED_SUPPORT
+
+ ifeq ($(CFG_CRYPT_ENABLE_CEPKA),y)
+ libname = crypto_engine_pka
+--
+2.14.1.windows.1
+